summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCaleb Maclennan2018-09-01 17:46:15 +0300
committerCaleb Maclennan2018-09-01 17:46:15 +0300
commit605f55f763584f895d4716beec8a31f5123bb5aa (patch)
tree89fdffdbe2917a58263857f1e56870074e9cdb38
parent8b5a9205bbd816a0e34437a241dece0032ba66a1 (diff)
downloadaur-605f55f763584f895d4716beec8a31f5123bb5aa.tar.gz
Cleanup bash shell quoting using shellharden
-rw-r--r--PKGBUILD6
1 files changed, 3 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d08427fde381..73e32be0fa10 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -36,7 +36,7 @@ sha512sums=('SKIP'
'90a0761b7709659bec6f29c366c503fdd348226cbb585cf4f6eaa065854e2027d08ab3b352eb13ad7c0e327d662f13bc00fb4163ea0c583ef55b1795ab2e0b31'
'c9820c2a83d08bd5d842a78e924682db97ebd5c7291b682603ad30dafcdcc5816c13e717ad39554f042b9d9ed71ab902ce3f604952264a900a72612ee8060acb')
_user=mastodon
-_homedir=/var/lib/${pkgname%-git}
+_homedir=/var/lib/"${pkgname%-git}"
_shell=/bin/false
pkgver() {
@@ -52,8 +52,8 @@ build() {
package() {
install -Dm 644 -t "$pkgdir"/usr/lib/systemd/system mastodon-{web,sidekiq,streaming}.service mastodon.target
- install -d "${pkgdir}/${_homedir}"
- rsync -av --exclude '.git' ${pkgname%-git}/ "${pkgdir}/${_homedir}/"
+ install -d "$pkgdir/$_homedir"
+ rsync -av --exclude '.git' "${pkgname%-git}"/ "$pkgdir/$_homedir/"
# install -Dm 644 .env.production.sample ${pkgdir}/etc/mastodon/env.production
}