summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichał Lisowski2020-04-21 19:57:59 +0200
committerMichał Lisowski2020-04-21 19:57:59 +0200
commit63d74e36c573e4b49bc06ea5c30bd7ce649b4774 (patch)
tree3e2798ce9f6577db31ed8293ed25cc0ad8feba4c
parent2f17915c56cf2cb09987127a1ff544aa964172f8 (diff)
downloadaur-63d74e36c573e4b49bc06ea5c30bd7ce649b4774.tar.gz
virtualenv and other improvements
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD26
2 files changed, 23 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f338b49d8ac5..ce86a42518c2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = maszyna-git
pkgdesc = Polish train simulator
pkgver = r1277.c45081b2
- pkgrel = 2
+ pkgrel = 3
url = https://eu07.pl/
arch = x86_64
license = MPL2
@@ -12,8 +12,11 @@ pkgbase = maszyna-git
makedepends = glm
makedepends = libserialport
makedepends = p7zip
- noextract = MaSzyna1908.zip
- noextract = 1908HF.zip
+ makedepends = python2-virtualenv
+ depends = glfw
+ depends = libserialport
+ noextract = MaSzyna.zip
+ noextract = HF.zip
source = maszyna-git::git://github.com/eu07/maszyna.git
source = http://stuff.eu07.pl/MaSzyna1908.zip
source = http://stuff.eu07.pl/1908HF.zip
diff --git a/PKGBUILD b/PKGBUILD
index 2e5fcce1ab17..cfd899a5b033 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,22 @@
# Maintainer: Michał Lisowski <lisu@riseup.net>
+_assets_ver=1908
+
pkgname=maszyna-git
pkgver=r1277.c45081b2
-pkgrel=2
+pkgrel=3
pkgdesc="Polish train simulator"
arch=('x86_64')
url="https://eu07.pl/"
license=('MPL2' 'custom')
-makedepends=('cmake' 'git' 'glfw' 'glm' 'libserialport' 'p7zip')
+makedepends=('cmake' 'git' 'glfw' 'glm' 'libserialport' 'p7zip' 'python2-virtualenv')
+depends=('glfw' 'libserialport')
source=("$pkgname"::'git://github.com/eu07/maszyna.git'
- "http://stuff.eu07.pl/MaSzyna1908.zip"
- "http://stuff.eu07.pl/1908HF.zip"
+ "http://stuff.eu07.pl/MaSzyna${_assets_ver}.zip"
+ "http://stuff.eu07.pl/${_assets_ver}HF.zip"
"https://eu07.pl/theme/Maszyna/dokumentacja/inne/readme_pliki/licencja.html")
-noextract=('MaSzyna1908.zip'
- '1908HF.zip')
+noextract=("MaSzyna${assets_ver}.zip"
+ "${assets_ver}HF.zip")
md5sums=('SKIP'
'1e33a4155c4dfeabfe8a72aaab6406be'
'70178c340fc236217343fe8ddcb63114'
@@ -39,7 +42,12 @@ build() {
package() {
cd "$srcdir/$pkgname"
install -D -m755 build/bin/eu07_$(date +'%y%m%d') "${pkgdir}/opt/maszyna/eu07"
- 7z x "${srcdir}/MaSzyna1908.zip" -o"${pkgdir}/opt/maszyna" -y
- 7z x "${srcdir}/1908HF.zip" -o"${pkgdir}/opt/maszyna" -y
- install -Dm644 licencja.html "${pkgdir}/usr/share/licenses/${pkgname}/license.html"
+ 7z x "${srcdir}/MaSzyna${assets_ver}.zip" -o"${pkgdir}/opt/maszyna" -y
+ 7z x "${srcdir}/${assets_ver}HF.zip" -o"${pkgdir}/opt/maszyna" -y
+ install -Dm644 "${srcdir}/licencja.html" "${pkgdir}/usr/share/licenses/${pkgname}/license.html"
+
+ cd "${pkgdir}/opt/maszyna"
+ virtualenv2 linuxpython64
+ source linuxpython64/bin/activate
+ pip2 install pillow
}