summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorYardena Cohen2022-02-18 20:53:35 -0800
committerYardena Cohen2022-02-18 21:12:22 -0800
commit62529cdfa382c440fb227e321aef86880307fd25 (patch)
treeee51d5a626fa683c70025eb2da6d06e048a0686d
downloadaur-mat2-git.tar.gz
init
-rw-r--r--.SRCINFO31
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD47
3 files changed, 82 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ba2524a2b70f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,31 @@
+pkgbase = mat2-git
+ pkgdesc = Metadata removal tool, supporting a wide range of commonly used file formats
+ pkgver = 0.12.3.1.g3509256
+ pkgrel = 1
+ url = https://0xacab.org/jvoisin/mat2
+ arch = any
+ license = LGPL3
+ checkdepends = ffmpeg
+ makedepends = python-setuptools
+ makedepends = git
+ depends = python
+ depends = python-mutagen
+ depends = python-cairo
+ depends = python-gobject
+ depends = gdk-pixbuf2
+ depends = poppler-glib
+ depends = librsvg
+ depends = perl-image-exiftool
+ depends = mailcap
+ optdepends = ffmpeg: video support
+ optdepends = bubblewrap: sandboxing support
+ provides = mat
+ provides = mat-git
+ provides = mat2
+ conflicts = mat
+ conflicts = mat-git
+ conflicts = mat2
+ source = git+https://0xacab.org/jvoisin/mat2.git
+ sha512sums = SKIP
+
+pkgname = mat2-git
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..b84c435bfd1a
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+/mat2-git-*.log
+/mat2-git-*.pkg.tar.xz
+/mat2/
+/src/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3fab036349d3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,47 @@
+# Maintainer: Yardena Cohen <yardenack@gmail.com>
+# Contributor: kpcyrd <kpcyrd[at]archlinux[dot]org>
+# Contributor: Francois Boulogne <devel at sciunto dot org>
+
+gitname=mat2
+pkgname=${gitname}-git
+pkgver=0.12.3.1.g3509256
+pkgrel=1
+pkgdesc='Metadata removal tool, supporting a wide range of commonly used file formats'
+url='https://0xacab.org/jvoisin/mat2'
+arch=('any')
+license=('LGPL3')
+depends=('python' 'python-mutagen' 'python-cairo' 'python-gobject' 'gdk-pixbuf2' 'poppler-glib' 'librsvg' 'perl-image-exiftool' 'mailcap')
+makedepends=('python-setuptools' git)
+optdepends=(
+ 'ffmpeg: video support'
+ 'bubblewrap: sandboxing support'
+)
+checkdepends=('ffmpeg')
+conflicts=(mat mat-git mat2)
+provides=(mat mat-git mat2)
+source=("git+https://0xacab.org/jvoisin/${gitname}.git")
+sha512sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/${gitname}"
+ local ver="$(git describe --tags | sed 's|-|\.|g')"
+ printf "%s" "${ver//-/.}"
+}
+build() {
+ cd "${srcdir}/${gitname}"
+ export PYTHONHASHSEED=0
+ python setup.py build
+}
+
+check() {
+ cd "${srcdir}/${gitname}"
+ python -m unittest discover -v
+}
+
+package() {
+ cd "${srcdir}/${gitname}"
+ python setup.py install --skip-build -O1 --root="${pkgdir}"
+ install -Dm 644 dolphin/mat2.desktop -t "${pkgdir}/usr/share/kservices5/ServiceMenus"
+ install -Dm 644 doc/mat2.1 -t "${pkgdir}/usr/share/man/man1"
+ install -Dm 644 doc/*.md -t "${pkgdir}/usr/share/doc/${pkgname}"
+}