summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2023-10-30 09:26:01 -0600
committerMark Wagie2023-10-30 09:26:01 -0600
commita444dfff6f080211b612c7ed383126752032e0c6 (patch)
treed1a65d131fba8ff30fe3ff2ca6656d0626eb8681
parent05710e8e31f8da6e6281907d9a56550f4e5575e5 (diff)
downloadaur-a444dfff6f080211b612c7ed383126752032e0c6.tar.gz
Set GTKSV_DIR to
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD14
2 files changed, 11 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 44af428bd2bf..a63e8f5d176a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,12 @@
pkgbase = matcha-gtk-theme
pkgdesc = A flat design theme for GTK 3, GTK 2 and GNOME Shell
pkgver = 2023.10.30
- pkgrel = 1
+ pkgrel = 2
url = https://vinceliuice.github.io/theme-matcha.html
install = matcha-gtk-theme.install
arch = any
license = GPL3
+ makedepends = setconf
optdepends = gtk-engine-murrine: GTK2 theme support
optdepends = gtk-engines: GTK2 theme support
optdepends = qogir-icon-theme: Recommended icon theme
diff --git a/PKGBUILD b/PKGBUILD
index 93610825ce94..367c71465937 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,11 +5,12 @@
pkgname=matcha-gtk-theme
_pkgver=2023-10-30
pkgver=${_pkgver//-/.}
-pkgrel=1
+pkgrel=2
pkgdesc="A flat design theme for GTK 3, GTK 2 and GNOME Shell"
arch=('any')
url="https://vinceliuice.github.io/theme-matcha.html"
license=('GPL3')
+makedepends=('setconf')
optdepends=('gtk-engine-murrine: GTK2 theme support'
'gtk-engines: GTK2 theme support'
'qogir-icon-theme: Recommended icon theme')
@@ -18,12 +19,15 @@ install="$pkgname.install"
source=("$pkgname-${_pkgver}.tar.gz::https://github.com/vinceliuice/Matcha-gtk-theme/archive/${_pkgver}.tar.gz")
sha256sums=('9e7c1b7055bd996eaa01e8cd30e098dc1873f98690d2ace6ecad0e945307d470')
+prepare() {
+ cd "Matcha-gtk-theme-${_pkgver}"
+
+ # Set GTKSV_DIR to $pkgdir
+ setconf install.sh GTKSV_DIR "$pkgdir/usr/share/gtksourceview-3.0/styles"
+}
+
package() {
cd "Matcha-gtk-theme-${_pkgver}"
install -d "$pkgdir/usr/share/themes"
./install.sh -d "$pkgdir/usr/share/themes/"
-
- # Install script fails to honor dest DIR for GTKSV_DIR, install files manually
- install -Dm644 src/extra/gtksourceview/*.xml -t \
- "$pkgdir/usr/share/gtksourceview-3.0/styles/"
}