summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKibouo2018-03-16 01:15:36 +0100
committerKibouo2018-03-16 01:15:36 +0100
commitfb839ce07e9f8f9142a07366e7c0e908ec744813 (patch)
tree0c69148a807f51a00c7f678e4595741906f438ac
downloadaur-fb839ce07e9f8f9142a07366e7c0e908ec744813.tar.gz
Publish package 20180316
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD28
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..08d4d807f792
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = matcha-gtk-theme-git
+ pkgdesc = A flat design theme for GTK3, GTK2, and Gnome-Shell.
+ pkgver = r98.1d71e77
+ pkgrel = 1
+ url = https://vinceliuice.github.io/theme-matcha
+ arch = any
+ license = GPL3
+ makedepends = git
+ depends = gtk-engine-murrine
+ depends = gtk-engines
+ depends = gtk3
+ provides = matcha-gtk-theme-git
+ conflicts = matcha-gtk-theme-git,
+ conflicts = matcha-gtk-theme
+ source = matcha-gtk-theme-git::git+https://github.com/vinceliuice/matcha.git
+ md5sums = SKIP
+
+pkgname = matcha-gtk-theme-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..86765f2a8fa8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Kibouo <csonka.mihaly@hotmail.com>
+pkgname=matcha-gtk-theme-git
+pkgver=r98.1d71e77
+pkgrel=1
+pkgdesc="A flat design theme for GTK3, GTK2, and Gnome-Shell."
+arch=('any')
+url='https://vinceliuice.github.io/theme-matcha'
+license=('GPL3')
+depends=('gtk-engine-murrine' 'gtk-engines' 'gtk3')
+makedepends=('git')
+provides=("${pkgname}")
+conflicts=("${pkgname}", "matcha-gtk-theme")
+source=("${pkgname}::git+https://github.com/vinceliuice/matcha.git")
+md5sums=('SKIP')
+pkgver() {
+ cd "${pkgname}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+package() {
+ mkdir "${pkgdir}"/usr
+ mkdir "${pkgdir}"/usr/share
+ mkdir "${pkgdir}"/usr/share/themes
+ cd "${pkgname}"
+ export _ORIGINAL_MATCHA_INSTALL_DIR=/usr/share/themes
+ export _NEW_MATCHA_INSTALL_DIR="${pkgdir}"/usr/share/themes
+ sed -i 's|'${_ORIGINAL_MATCHA_INSTALL_DIR}'|'${_NEW_MATCHA_INSTALL_DIR}'|g' ./Install
+ ./Install
+} \ No newline at end of file