summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSergey Shatunov2018-09-22 01:01:35 +0700
committerSergey Shatunov2018-09-22 01:01:35 +0700
commit4a3b1a39b41dfd31704666c9ea8b751220e7db86 (patch)
tree301b1fa0fcb20bee671ec45704751aac481e90f0
parent08202faff44ba260becad8989e3cb8d1c360c9c5 (diff)
downloadaur-4a3b1a39b41dfd31704666c9ea8b751220e7db86.tar.gz
Migrate to sysusers+tmpfiles solution
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD13
-rw-r--r--matchbox.sysusers2
-rw-r--r--matchbox.tmpfiles3
4 files changed, 20 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c7ca761b4fc6..53e5920896f5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = matchbox
pkgdesc = Network boot and provision Container Linux clusters
pkgver = 0.7.0
- pkgrel = 2
+ pkgrel = 3
url = https://coreos.com/matchbox/docs/latest/
arch = x86_64
arch = i686
@@ -13,7 +13,11 @@ pkgbase = matchbox
makedepends = go
makedepends = git
source = git+https://github.com/coreos/matchbox.git#commit=08f4e9908b167fba608e60169ec6a803df9db37f
- md5sums = SKIP
+ source = matchbox.sysusers
+ source = matchbox.tmpfiles
+ sha256sums = SKIP
+ sha256sums = b5a40ff91c6b14fcfc6261a64a1221bc2dd20403ab5727fa8c3719fe4e3a36ea
+ sha256sums = d3fc3cd0261959e76c692a5511f7fbb0f297c62e9a2664eb0e9735cb17adc455
pkgname = matchbox
diff --git a/PKGBUILD b/PKGBUILD
index b4cfb72c3c06..0a945c2abfa3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Sergey Shatunov <me@prok.pw>
pkgname=matchbox
pkgver=0.7.0
-pkgrel=2
+pkgrel=3
pkgdesc="Network boot and provision Container Linux clusters"
arch=("x86_64" "i686" "arm" "armv6h" "armv7h" "aarch64")
url="https://coreos.com/matchbox/docs/latest/"
@@ -9,8 +9,12 @@ license=('Apache')
makedepends=('go' 'git')
_goname=github.com/coreos/$pkgname
_commit=08f4e9908b167fba608e60169ec6a803df9db37f # 0.7.0
-source=("git+https://$_goname.git#commit=$_commit")
-md5sums=('SKIP')
+source=("git+https://$_goname.git#commit=$_commit"
+ "matchbox.sysusers"
+ "matchbox.tmpfiles")
+sha256sums=('SKIP'
+ 'b5a40ff91c6b14fcfc6261a64a1221bc2dd20403ab5727fa8c3719fe4e3a36ea'
+ 'd3fc3cd0261959e76c692a5511f7fbb0f297c62e9a2664eb0e9735cb17adc455')
pkgver() {
mkdir -p $srcdir/src/github.com/coreos
@@ -30,6 +34,7 @@ package() {
install -Dm755 bin/$pkgname "$pkgdir/usr/bin/$pkgname"
objcopy --remove-section .note.go.buildid "$pkgdir/usr/bin/$pkgname"
install -Dm644 contrib/systemd/$pkgname.service "$pkgdir/usr/lib/systemd/system/$pkgname.service"
- install -dm755 "$pkgdir/var/lib/matchbox{,/assets}"
+ install -Dm644 $srcdir/matchbox.sysusers "$pkgdir/usr/lib/sysusers.d/$pkgname.conf"
+ install -Dm644 $srcdir/matchbox.tmpfiles "$pkgdir/usr/lib/tmpfiles.d/$pkgname.conf"
install -dm755 "$pkgdir/etc/matchbox"
}
diff --git a/matchbox.sysusers b/matchbox.sysusers
new file mode 100644
index 000000000000..1be65db1018d
--- /dev/null
+++ b/matchbox.sysusers
@@ -0,0 +1,2 @@
+u matchbox - "matchbox daemon user" /var/lib/matchbox
+
diff --git a/matchbox.tmpfiles b/matchbox.tmpfiles
new file mode 100644
index 000000000000..0173664dbb6f
--- /dev/null
+++ b/matchbox.tmpfiles
@@ -0,0 +1,3 @@
+d /var/lib/matchbox 0755 matchbox matchbox
+d /var/lib/matchbox/assets 0755 matchbox matchbox
+