summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSergey Shatunov2018-09-22 00:04:56 +0700
committerSergey Shatunov2018-09-22 00:04:56 +0700
commita937449bdb91e0fca0cead958d4af98d9a13e8eb (patch)
treea6b0edde04e1e6809c20736d06afdcdf3ebf6fe0
downloadaur-a937449bdb91e0fca0cead958d4af98d9a13e8eb.tar.gz
Initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD33
2 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..bba76dbc361c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = matchbox
+ pkgdesc = Network boot and provision Container Linux clusters
+ pkgver = 0.7.0
+ pkgrel = 1
+ url = https://coreos.com/matchbox/docs/latest/
+ arch = x86_64
+ arch = i686
+ arch = arm
+ arch = armv6h
+ arch = armv7h
+ arch = aarch64
+ license = Apache
+ makedepends = go
+ makedepends = git
+ source = git+https://github.com/coreos/matchbox.git#commit=08f4e9908b167fba608e60169ec6a803df9db37f
+ md5sums = SKIP
+
+pkgname = matchbox
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..46cae05d2d5c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Sergey Shatunov <me@prok.pw>
+pkgname=matchbox
+pkgver=0.7.0
+pkgrel=1
+pkgdesc="Network boot and provision Container Linux clusters"
+arch=("x86_64" "i686" "arm" "armv6h" "armv7h" "aarch64")
+url="https://coreos.com/matchbox/docs/latest/"
+license=('Apache')
+makedepends=('go' 'git')
+_goname=github.com/coreos/$pkgname
+_commit=08f4e9908b167fba608e60169ec6a803df9db37f # 0.7.0
+source=("git+https://$_goname.git#commit=$_commit")
+md5sums=('SKIP')
+
+pkgver() {
+ mkdir -p $srcdir/src/github.com/coreos
+ ln -sf $srcdir/$pkgname $srcdir/src/$_goname
+
+ cd $pkgname
+ git describe --tags | sed 's/^v//;s/-/+/g'
+}
+
+build() {
+ cd $pkgname
+ GOPATH="$srcdir" make bin/matchbox
+}
+
+package() {
+ cd $pkgname
+ install -Dm755 bin/$pkgname "$pkgdir/usr/bin/$pkgname"
+ objcopy --remove-section .note.go.buildid "$pkgdir/usr/bin/$pkgname"
+ install -Dm544 contrib/systemd/$pkgname.service "$pkgdir/usr/lib/systemd/system/$pkgname.service"
+}