summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBartłomiej Piotrowski2018-01-05 21:19:05 +0100
committerBartłomiej Piotrowski2018-01-05 21:19:05 +0100
commit3de40e5af8009a1c5aa952d7e593d687988e4b3d (patch)
tree4b23bbf783356e0145845e9b9acc46e4862a0cc1
downloadaur-matchbox-panel.tar.gz
Import from official repositories
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD33
2 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4dbb8c945312
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = matchbox-panel
+ pkgdesc = A flexible always present 'window bar' for holding application launchers and small 'applet' style applications
+ pkgver = 2.11
+ pkgrel = 1
+ url = http://matchbox-project.org/
+ arch = x86_64
+ license = GPL
+ depends = libmatchbox
+ depends = startup-notification
+ depends = libpng
+ depends = gtk3
+ depends = dbus-glib
+ source = http://git.yoctoproject.org/cgit/cgit.cgi/matchbox-panel-2/snapshot/matchbox-panel-2-2.11.tar.bz2
+ sha256sums = f357ea9bb95b4219a09fe77fcb344f4618e588bc082dadfe3f72e051a7411917
+
+pkgname = matchbox-panel
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f59929451c01
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# $Id: PKGBUILD 266875 2017-11-15 14:29:11Z foutrelis $
+# Maintainer: Sergej Pupykin <pupykin.s+arch@gmail.com>
+# Contributor: Henrique C. Alves <hcarvalhoalves@gmail.com>
+
+pkgname=matchbox-panel
+pkgver=2.11
+pkgrel=1
+pkgdesc="A flexible always present 'window bar' for holding application launchers and small 'applet' style applications"
+arch=('x86_64')
+license=('GPL')
+depends=('libmatchbox' 'startup-notification' 'libpng' 'gtk3' 'dbus-glib')
+url="http://matchbox-project.org/"
+source=("http://git.yoctoproject.org/cgit/cgit.cgi/matchbox-panel-2/snapshot/matchbox-panel-2-$pkgver.tar.bz2")
+sha256sums=('f357ea9bb95b4219a09fe77fcb344f4618e588bc082dadfe3f72e051a7411917')
+
+prepare() {
+ cd "$srcdir"/$pkgname-2-$pkgver
+ find -type f -name 'Makefile*' -exec sed -i 's|-Werror||g' {} \;
+ sed -i 's|sync |xsync |g' applets/showdesktop/showdesktop.c
+}
+
+build() {
+ cd "$srcdir"/$pkgname-2-$pkgver
+ ./autogen.sh
+ ./configure --sysconfdir=/etc --prefix=/usr \
+ --enable-startup-notification
+ make
+}
+
+package() {
+ cd "$srcdir"/$pkgname-2-$pkgver
+ make DESTDIR="$pkgdir" install
+}