summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBłażej Szczygieł2016-05-28 12:07:06 +0200
committerBłażej Szczygieł2016-05-28 12:07:06 +0200
commit065bf531662df83d563d06e04fd8491ddd33c07c (patch)
tree49ca1979677fc8128b8bea14994734c358376d50
parent4ae7eac799a664db4631882cbc69465dc01a615c (diff)
downloadaur-065bf531662df83d563d06e04fd8491ddd33c07c.tar.gz
Fix compilation for new MATE
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD7
-rw-r--r--org.mate.calc.gschema.xml.in.patch93
3 files changed, 102 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1f2638270ca6..8db29aa47183 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,9 @@
+# Generated by mksrcinfo v8
+# Sat May 28 10:06:34 UTC 2016
pkgbase = mate-calc-git
pkgdesc = Calculator for the Mate desktop environment
pkgver = 1.8.0
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/mate-desktop/mate-calc
install = mate-calc-git.install
arch = i686
@@ -16,7 +18,9 @@ pkgbase = mate-calc-git
depends = mate-common
provides = mate-calc
source = git+https://github.com/mate-desktop/mate-calc#branch=fixes
+ source = org.mate.calc.gschema.xml.in.patch
sha1sums = SKIP
+ sha1sums = e3cae557dee7c339236bdd7fff43a81e00d5b4d8
pkgname = mate-calc-git
diff --git a/PKGBUILD b/PKGBUILD
index a3256636320f..017d047f5aec 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=mate-calc-git
pkgver=1.8.0
-pkgrel=2
+pkgrel=3
pkgdesc='Calculator for the Mate desktop environment'
arch=('i686' 'x86_64')
url='https://github.com/mate-desktop/mate-calc'
@@ -11,13 +11,14 @@ groups=('mate-extra')
depends=('mate-common')
makedepends=('make' 'gcc' 'autoconf' 'intltool' 'pkg-config')
provides=('mate-calc')
-source=("git+https://github.com/mate-desktop/mate-calc#branch=fixes")
-sha1sums=(SKIP)
+source=("git+https://github.com/mate-desktop/mate-calc#branch=fixes" "org.mate.calc.gschema.xml.in.patch")
+sha1sums=('SKIP' 'e3cae557dee7c339236bdd7fff43a81e00d5b4d8')
install=$pkgname.install
build()
{
cd mate-calc
+ patch -p1 < ../org.mate.calc.gschema.xml.in.patch
sh autogen.sh --prefix=/usr
make
}
diff --git a/org.mate.calc.gschema.xml.in.patch b/org.mate.calc.gschema.xml.in.patch
new file mode 100644
index 000000000000..75f0210cc889
--- /dev/null
+++ b/org.mate.calc.gschema.xml.in.patch
@@ -0,0 +1,93 @@
+diff -Naur mate-calc.orig/data/org.mate.calc.gschema.xml.in mate-calc/data/org.mate.calc.gschema.xml.in
+--- mate-calc.orig/data/org.mate.calc.gschema.xml.in 2016-05-28 12:02:39.653582000 +0200
++++ mate-calc/data/org.mate.calc.gschema.xml.in 2016-05-28 12:03:49.076918330 +0200
+@@ -22,65 +22,65 @@
+ <key type="i" name="accuracy">
+ <default>9</default>
+ <range min="0" max="9"/>
+- <_summary>Accuracy value</_summary>
+- <_description>The number of digits displayed after the numeric point</_description>
++ <summary>Accuracy value</summary>
++ <description>The number of digits displayed after the numeric point</description>
+ </key>
+ <key type="i" name="word-size">
+ <default>64</default>
+ <range min="8" max="64"/>
+- <_summary>Word size</_summary>
+- <_description>The size of the words used in bitwise operations</_description>
++ <summary>Word size</summary>
++ <description>The size of the words used in bitwise operations</description>
+ </key>
+ <key type="i" name="base">
+ <default>10</default>
+ <range min="2" max="16"/>
+- <_summary>Numeric Base</_summary>
+- <_description>The numeric base</_description>
++ <summary>Numeric Base</summary>
++ <description>The numeric base</description>
+ </key>
+ <key type="b" name="show-thousands">
+ <default>false</default>
+- <_summary>Show Thousands Separators</_summary>
+- <_description>Indicates whether thousands separators are shown in large numbers.</_description>
++ <summary>Show Thousands Separators</summary>
++ <description>Indicates whether thousands separators are shown in large numbers.</description>
+ </key>
+ <key type="b" name="show-zeroes">
+ <default>false</default>
+- <_summary>Show Trailing Zeroes</_summary>
+- <_description>Indicates whether any trailing zeroes after the numeric point should be shown in the display value.</_description>
++ <summary>Show Trailing Zeroes</summary>
++ <description>Indicates whether any trailing zeroes after the numeric point should be shown in the display value.</description>
+ </key>
+ <key name="number-format" enum="org.mate.calc.NumberFormat">
+ <default>'automatic'</default>
+- <_summary>Number format</_summary>
+- <_description>The format to display numbers in</_description>
++ <summary>Number format</summary>
++ <description>The format to display numbers in</description>
+ </key>
+ <key name="angle-units" enum="org.mate.calc.AngleUnit">
+ <default>'degrees'</default>
+- <_summary>Angle units</_summary>
+- <_description>The angle units to use</_description>
++ <summary>Angle units</summary>
++ <description>The angle units to use</description>
+ </key>
+ <key name="button-mode" enum="org.mate.calc.ButtonMode">
+ <default>'basic'</default>
+- <_summary>Button mode</_summary>
+- <_description>The button mode</_description>
++ <summary>Button mode</summary>
++ <description>The button mode</description>
+ </key>
+ <key type="s" name="source-currency">
+ <default>''</default>
+- <_summary>Source currency</_summary>
+- <_description>Currency of the current calculation</_description>
++ <summary>Source currency</summary>
++ <description>Currency of the current calculation</description>
+ </key>
+ <key type="s" name="target-currency">
+ <default>''</default>
+- <_summary>Target currency</_summary>
+- <_description>Currency to convert the current calculation into</_description>
++ <summary>Target currency</summary>
++ <description>Currency to convert the current calculation into</description>
+ </key>
+ <key type="s" name="source-units">
+ <default>'degree'</default>
+- <_summary>Source units</_summary>
+- <_description>Units of the current calculation</_description>
++ <summary>Source units</summary>
++ <description>Units of the current calculation</description>
+ </key>
+ <key type="s" name="target-units">
+ <default>'radian'</default>
+- <_summary>Target units</_summary>
+- <_description>Units to convert the current calculation into</_description>
++ <summary>Target units</summary>
++ <description>Units to convert the current calculation into</description>
+ </key>
+ </schema>
+ </schemalist>