summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorElrondo462020-04-06 20:09:05 +0200
committerElrondo462020-04-06 20:09:05 +0200
commitb3b6347dda8957a3c557f11e1326261495c04b32 (patch)
tree7eeb07080f790855997fbe43a909b9de1f6e5e74
downloadaur-b3b6347dda8957a3c557f11e1326261495c04b32.tar.gz
First release
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD23
2 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..95af662be083
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = mate-fastcomposwitch
+ pkgdesc = Compositor or not with a simple systray icon
+ pkgver = 20200406
+ pkgrel = 1
+ arch = x86_64
+ license = GPL
+ depends = python-gobject
+ depends = caja
+ depends = libappindicator-gtk3
+ source = git://github.com/Elrondo46/mate-fastcomposwitch.git
+ md5sums = SKIP
+
+pkgname = mate-fastcomposwitch
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7c10a548e08d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer:XXXXXXXXXXXXXXXXXXXXXXXXXXX
+pkgname=mate-fastcomposwitch
+pkgver=20200406
+pkgrel=1
+pkgdesc="Compositor or not with a simple systray icon"
+arch=(x86_64)
+license=('GPL')
+depends=('python-gobject' 'caja' 'libappindicator-gtk3')
+source=(git://github.com/Elrondo46/mate-fastcomposwitch.git)
+md5sums=('SKIP')
+
+pkgver() {
+ # Identify latest version.
+ cd "$srcdir/mate-fastcomposwitch"
+ git log -1 --format="%cd" --date=short | sed 's|-||g'
+}
+
+package() {
+ install -Dm644 "mate-fastcomposwitch/marcosystray.desktop" "${pkgdir}/usr/share/applications/marcosystray.desktop"
+ install -Dm755 "mate-fastcomposwitch/marcosystray" "${pkgdir}/usr/bin/marcosystray"
+ install -Dm644 "mate-fastcomposwitch/icons/mate-fast-composwitch-active.png" "${pkgdir}/usr/share/icons/mate-fast-composwitch-active.png"
+ install -Dm644 "mate-fastcomposwitch/icons/mate-fast-composwitch-inactive.png" "${pkgdir}/usr/share/icons/mate-fast-composwitch-inactive.png"
+}