summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorIKRadulov2016-08-01 11:13:08 +0300
committerIKRadulov2016-08-01 11:13:08 +0300
commitcaf21f8731bd926b3bf12a31dfecd35257017e6f (patch)
tree9fcde15b4eb60b410d246c66e315f3db994f69ea
downloadaur-caf21f8731bd926b3bf12a31dfecd35257017e6f.tar.gz
first build
-rw-r--r--.SRCINFO28
-rw-r--r--PKGBUILD28
2 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6487d00c8582
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,28 @@
+pkgbase = mate-hud
+ pkgdesc = Unity like HUD for Mate
+ pkgver = 16.10.0
+ pkgrel = 1
+ url = https://bitbucket.org/ubuntu-mate/mate-hud.git
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = appmenu-qt
+ depends = libkeybinder3
+ depends = mate-desktop
+ depends = python
+ depends = python-dbus
+ depends = python-psutil
+ depends = python-setproctitle
+ depends = python-xlib
+ depends = rofi
+ depends = unity-gtk-module
+ provides = mate-hud
+ provides = mate-hud
+ conflicts = mate-hud
+ conflicts = mate-hud
+ source = https://bitbucket.org/ubuntu-mate/mate-hud/get/16.10.0.tar.gz
+ sha1sums = 42e774916f021b411c8c39240118c8fb11f8b3a4
+
+pkgname = mate-hud
+ groups = mate-extra
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..173feb7dc159
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: IKRadulov <ikradulov@vivaldi.net>
+# Contributors:
+
+_ver=16.10
+_gitcom=d6f2a2fae6eb
+_pkgbase=mate-hud
+pkgname="${_pkgbase}"
+pkgver=${_ver}.0
+pkgrel=1
+pkgdesc="Unity like HUD for Mate"
+url="https://bitbucket.org/ubuntu-mate/mate-hud.git"
+arch=('i686' 'x86_64')
+provides=("${_pkgbase}" "${_pkgbase}")
+conflicts=("${_pkgbase}" "${_pkgbase}")
+license=('GPL')
+depends=('appmenu-qt' 'libkeybinder3' 'mate-desktop' 'python' 'python-dbus' 'python-psutil' 'python-setproctitle' 'python-xlib' 'rofi' 'unity-gtk-module')
+source=("https://bitbucket.org/ubuntu-mate/mate-hud/get/16.10.0.tar.gz")
+sha1sums=('42e774916f021b411c8c39240118c8fb11f8b3a4')
+
+prepare() {
+ msg "This will only work if you have UnityForArch repository"
+}
+
+package() {
+ groups=('mate-extra')
+ cd "${srcdir}/ubuntu-mate-mate-hud-${_gitcom}"
+ ./setup.py "install" "--root=${pkgdir}" "--optimize=1"
+}