summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander F. Rødseth2019-03-27 10:18:16 +0100
committerAlexander F. Rødseth2019-03-27 10:18:16 +0100
commitd76cbc5bd91649434dde95546642ebb56724be5f (patch)
treee802fd4c5eda59860312bfcf385dea986be67707
parent643fd80ed2293b79e20b8e97d8d957b0ef3dfb64 (diff)
downloadaur-d76cbc5bd91649434dde95546642ebb56724be5f.tar.gz
Move from [community] to AUR in connection with the spring cleaning
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD19
2 files changed, 15 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3d7031eefa65..50035a00155f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,10 @@
# Generated by mksrcinfo v8
-# Mon Mar 21 18:08:20 UTC 2016
+# Wed Mar 27 09:16:00 UTC 2019
pkgbase = mate-menu
pkgdesc = Advanced menu for MATE Panel, a fork of MintMenu
- pkgver = 5.6.9
+ pkgver = 18.04.3
pkgrel = 1
- url = https://bitbucket.org/ubuntu-mate/mate-menu
- install = mate-menu.install
+ url = https://github.com/ubuntu-mate/mate-menu
arch = any
license = GPL
makedepends = python2-distutils-extra
@@ -17,8 +16,9 @@ pkgbase = mate-menu
depends = python2-xdg
depends = python2-xlib
depends = xdg-utils
- source = mate-menu-5.6.9.tar.gz::https://bitbucket.org/ubuntu-mate/mate-menu/get/5.6.9.tar.gz
- sha256sums = 5eb733dbd4bd12fc268e107050d703904fefb0e639defe374bd70389e951e1f2
+ depends = python2-setproctitle
+ source = mate-menu-18.04.3.tar.gz::https://github.com/ubuntu-mate/mate-menu/archive/18.04.3.tar.gz
+ sha256sums = 8fe0ccbc667ca7f6cb1cd6a7d86961e755ce53e7360e6e59a45a4eeae13b1331
pkgname = mate-menu
diff --git a/PKGBUILD b/PKGBUILD
index 37e6b8361ca0..a045dcfe3381 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,24 @@
-# $Id$
-# Maintainer: Balló György <ballogyor+arch at gmail dot com>
+# Maintainer:
+# Contriburor: Balló György <ballogyor+arch at gmail dot com>
pkgname=mate-menu
-pkgver=5.6.9
+pkgver=18.04.3
pkgrel=1
pkgdesc="Advanced menu for MATE Panel, a fork of MintMenu"
arch=('any')
-url="https://bitbucket.org/ubuntu-mate/mate-menu"
+url="https://github.com/ubuntu-mate/mate-menu"
license=('GPL')
-depends=('mate-panel' 'python2-configobj' 'python2-gobject' 'python2-pyinotify' 'python2-xdg' 'python2-xlib' 'xdg-utils')
+depends=('mate-panel' 'python2-configobj' 'python2-gobject' 'python2-pyinotify' 'python2-xdg' 'python2-xlib' 'xdg-utils' 'python2-setproctitle')
makedepends=('python2-distutils-extra' 'python2-setuptools')
-install=$pkgname.install
-source=("$pkgname-$pkgver.tar.gz::https://bitbucket.org/ubuntu-mate/$pkgname/get/$pkgver.tar.gz")
-sha256sums=('5eb733dbd4bd12fc268e107050d703904fefb0e639defe374bd70389e951e1f2')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/ubuntu-mate/mate-menu/archive/$pkgver.tar.gz")
+sha256sums=('8fe0ccbc667ca7f6cb1cd6a7d86961e755ce53e7360e6e59a45a4eeae13b1331')
prepare() {
- cd ubuntu-mate-$pkgname-*
+ cd $pkgname-$pkgver
sed -i 's@^#!.*python$@#!/usr/bin/python2@' lib/*.py
}
package() {
- cd ubuntu-mate-$pkgname-*
+ cd $pkgname-$pkgver
python2 setup.py install --root="$pkgdir" --optimize=1
}