summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorValHue2018-04-27 17:55:06 +0200
committerValHue2018-04-27 17:55:06 +0200
commitc34b3bd6f8cee214c2be71286be4e172407ecede (patch)
tree4b3c8bfe46da77e179e6c3bcbbc2b11e89eef34b
downloadaur-c34b3bd6f8cee214c2be71286be4e172407ecede.tar.gz
Initial import
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD29
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..dcf98ff79cc7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = mate-notification-theme-slate
+ pkgdesc = A CSS-backed notification theme for the MATE Desktop. \n The fallback styling for this plugin emulates the Arc-styled Budgie notifications.
+ pkgver = 5
+ pkgrel = 1
+ url = https://github.com/solus-project/mate-notification-theme-slate
+ arch = i686
+ arch = x86_64
+ license = LGPL2.1
+ depends = gtk3
+ provides = mate-notification-theme-slate
+ source = mate-notification-theme-slate-5.tar.gz::https://github.com/solus-project/mate-notification-theme-slate/archive/v5.tar.gz
+ sha256sums = 966f0fc81711ffd47213c2710cb4ccd0625895542c1c5439067048530abe5621
+
+pkgname = mate-notification-theme-slate
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..56a6fa013e86
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: ValHue <vhuelamo at gmail dot com>
+#
+# Contributor: ValHue <vhuelamo at gmail dot com>
+#
+pkgname="mate-notification-theme-slate"
+pkgver=5
+pkgrel=1
+pkgdesc="A CSS-backed notification theme for the MATE Desktop. \n
+ The fallback styling for this plugin emulates the Arc-styled Budgie notifications. "
+url="https://github.com/solus-project/mate-notification-theme-slate"
+arch=('i686' 'x86_64')
+license=('LGPL2.1')
+depends=('gtk3')
+provides=("${pkgname}")
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/solus-project/${pkgname}/archive/v5.tar.gz")
+sha256sums=('966f0fc81711ffd47213c2710cb4ccd0625895542c1c5439067048530abe5621')
+
+build() {
+ cd "${pkgname}-${pkgver}"
+ ./autogen.sh --prefix=/usr
+ make -j$(($(getconf _NPROCESSORS_ONLN)+1))
+}
+
+package() {
+ cd "${pkgname}-${pkgver}"
+ make DESTDIR=${pkgdir} install
+}
+
+# vim:set ts=4 sw=2 ft=sh et syn=sh ft=sh: