summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBalló György2016-02-26 05:31:06 +0100
committerBalló György2016-02-26 05:31:06 +0100
commit89d458894e71a503d2a05403af2350710d7f8f3d (patch)
treedf782ed8e80452036c1a03423225d8f1df4f0647
parent2c79ed76f32c01c911da5e6818e05b6a705ca8f3 (diff)
downloadaur-89d458894e71a503d2a05403af2350710d7f8f3d.tar.gz
upgpkg: mate-tweak 3.5.6-2
Add more panel layouts
-rw-r--r--.SRCINFO17
-rw-r--r--0001-Fix-checking-available-features.patch50
-rw-r--r--PKGBUILD29
-rw-r--r--fix-mutiny-fresh.patch18
4 files changed, 107 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ac2996e7bce0..1a5277246865 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Sun Feb 21 12:31:31 UTC 2016
+# Fri Feb 26 04:31:06 UTC 2016
pkgbase = mate-tweak
pkgdesc = Tweak tool for MATE, a fork of mintDesktop
pkgver = 3.5.6
- pkgrel = 1
+ pkgrel = 2
url = https://bitbucket.org/ubuntu-mate/mate-tweak
arch = any
license = GPL
@@ -12,12 +12,23 @@ pkgbase = mate-tweak
makedepends = python-setuptools
depends = gtk3
depends = libnotify
- depends = mate-panel
+ depends = mate-applets
depends = python-configobj
depends = python-gobject
depends = python-psutil
+ optdepends = gnome-main-menu: for openSUSE panel layout
+ optdepends = mate-applet-dock: for Mutiny panel layout
+ optdepends = mate-menu: to enable advanced menu
+ optdepends = plank: for Cupertino panel layout
+ optdepends = topmenu-gtk: for Mutiny panel layout
source = mate-tweak-3.5.6::git+https://bitbucket.org/ubuntu-mate/mate-tweak.git#tag=3.5.6
+ source = https://launchpad.net/ubuntu/+archive/primary/+files/ubuntu-mate-settings_16.04.2.tar.xz
+ source = 0001-Fix-checking-available-features.patch
+ source = fix-mutiny-fresh.patch
md5sums = SKIP
+ md5sums = 9003c6af0c1851c6e7a5926fe061d258
+ md5sums = 1717e0df056603a840b1f1daa52cdb13
+ md5sums = e389460b0f34dc6da6622830efa05273
pkgname = mate-tweak
diff --git a/0001-Fix-checking-available-features.patch b/0001-Fix-checking-available-features.patch
new file mode 100644
index 000000000000..7887263ad743
--- /dev/null
+++ b/0001-Fix-checking-available-features.patch
@@ -0,0 +1,50 @@
+From c69c3105073a534015ca3d9edf9b6902836dc02d Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Ball=C3=B3=20Gy=C3=B6rgy?= <ballogyor@gmail.com>
+Date: Fri, 26 Feb 2016 04:39:33 +0100
+Subject: [PATCH] Fix checking available features
+
+Indicators and advanced menu are need to be checked in the update_panel_layout_features function, othervise it's always enabled if the layouts files are availabe.
+---
+ mate-tweak | 19 ++++++++-----------
+ 1 file changed, 8 insertions(+), 11 deletions(-)
+
+diff --git a/mate-tweak b/mate-tweak
+index a31622b..7d8f058 100755
+--- a/mate-tweak
++++ b/mate-tweak
+@@ -409,8 +409,14 @@ class MateTweak:
+ if self.panel_layout_exists(panel_layout + '-fresh') and \
+ self.panel_layout_exists(panel_layout + '-indicators') and \
+ self.panel_layout_exists(panel_layout + '-indicators-fresh'):
+- self.builder.get_object('checkbutton_indicators').props.sensitive = True
+- self.builder.get_object('checkbutton_advanced_menu').props.sensitive = True
++ if not self.indicators_available:
++ self.builder.get_object('checkbutton_indicators').props.sensitive = False
++ else:
++ self.builder.get_object('checkbutton_indicators').props.sensitive = True
++ if not self.mate_menu_available:
++ self.builder.get_object('checkbutton_advanced_menu').props.sensitive = False
++ else:
++ self.builder.get_object('checkbutton_advanced_menu').props.sensitive = True
+ else:
+ self.builder.get_object('checkbutton_indicators').props.sensitive = False
+ self.builder.get_object('checkbutton_advanced_menu').props.sensitive = False
+@@ -664,15 +670,6 @@ class MateTweak:
+
+
+ def make_list_of_panel_layouts(self):
+- if not self.indicators_available:
+- self.builder.get_object('checkbutton_indicators').props.sensitive = False
+- else:
+- self.builder.get_object('checkbutton_indicators').props.sensitive = True
+- if not self.mate_menu_available:
+- self.builder.get_object('checkbutton_advanced_menu').props.sensitive = False
+- else:
+- self.builder.get_object('checkbutton_advanced_menu').props.sensitive = True
+-
+ # Panel layouts
+ panels = Gtk.ListStore(str, str)
+
+--
+2.7.1
+
diff --git a/PKGBUILD b/PKGBUILD
index 96ff8fc66eba..dd3154280133 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,17 +3,38 @@
pkgname=mate-tweak
pkgver=3.5.6
-pkgrel=1
+_umsver=16.04.2
+pkgrel=2
pkgdesc="Tweak tool for MATE, a fork of mintDesktop"
arch=('any')
url="https://bitbucket.org/ubuntu-mate/mate-tweak"
license=('GPL')
-depends=('gtk3' 'libnotify' 'mate-panel' 'python-configobj' 'python-gobject' 'python-psutil')
+depends=('gtk3' 'libnotify' 'mate-applets' 'python-configobj' 'python-gobject' 'python-psutil')
makedepends=('git' 'python-distutils-extra' 'python-setuptools')
-source=("$pkgname-$pkgver::git+https://bitbucket.org/ubuntu-mate/$pkgname.git#tag=$pkgver")
-md5sums=('SKIP')
+optdepends=('gnome-main-menu: for openSUSE panel layout'
+ 'mate-applet-dock: for Mutiny panel layout'
+ 'mate-menu: to enable advanced menu'
+ 'plank: for Cupertino panel layout'
+ 'topmenu-gtk: for Mutiny panel layout')
+source=("$pkgname-$pkgver::git+https://bitbucket.org/ubuntu-mate/$pkgname.git#tag=$pkgver"
+ "https://launchpad.net/ubuntu/+archive/primary/+files/ubuntu-mate-settings_$_umsver.tar.xz"
+ "0001-Fix-checking-available-features.patch"
+ "fix-mutiny-fresh.patch")
+md5sums=('SKIP'
+ '9003c6af0c1851c6e7a5926fe061d258'
+ '1717e0df056603a840b1f1daa52cdb13'
+ 'e389460b0f34dc6da6622830efa05273')
+
+prepare() {
+ cd $pkgname-$pkgver
+ patch -Np1 -i ../0001-Fix-checking-available-features.patch
+ sed -i 's|/usr/lib/mate-applets/topmenu-mate-panel-applet|/usr/lib/topmenu-gtk/topmenu-mate-panel-applet|' mate-tweak
+ cd ../ubuntu-mate-settings-16.04.1
+ patch -Np1 -i ../fix-mutiny-fresh.patch
+}
package() {
cd $pkgname-$pkgver
python3 setup.py install --root="$pkgdir" --optimize=1
+ cp -r "$srcdir/ubuntu-mate-settings-16.04.1/usr/share/mate-panel" "$pkgdir/usr/share"
}
diff --git a/fix-mutiny-fresh.patch b/fix-mutiny-fresh.patch
new file mode 100644
index 000000000000..ebc0d0a303e3
--- /dev/null
+++ b/fix-mutiny-fresh.patch
@@ -0,0 +1,18 @@
+diff -Naur ubuntu-mate-settings-16.04.1.orig/usr/share/mate-panel/layouts/mutiny-fresh.panel ubuntu-mate-settings-16.04.1/usr/share/mate-panel/layouts/mutiny-fresh.panel
+--- ubuntu-mate-settings-16.04.1.orig/usr/share/mate-panel/layouts/mutiny-fresh.panel 2016-02-21 19:16:14.000000000 +0100
++++ ubuntu-mate-settings-16.04.1/usr/share/mate-panel/layouts/mutiny-fresh.panel 2016-02-26 04:51:48.024833424 +0100
+@@ -16,6 +16,14 @@
+ screen=0
+ size=24
+
++[objects/topmenu]
++applet-iid='TopMenuMatePanelAppletFactory::TopMenuMatePanelApplet'
++locked=true
++toplevel-id='top'
++position=48
++object-type='applet'
++panel-right-stick=false
++
+ [objects/notification-area]
+ applet-iid='NotificationAreaAppletFactory::NotificationArea'
+ locked=true