summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFrederic Bezies2018-03-04 14:08:49 +0100
committerFrederic Bezies2018-03-04 14:08:49 +0100
commit6f3abb71473fe306fd0a0b4fd16b4f355d26c2c1 (patch)
tree34e1166c2fc1115a807b44cb4228b0e5525caa7c
parent5acfac09a39bc54a795f258dd136089676898179 (diff)
downloadaur-6f3abb71473fe306fd0a0b4fd16b4f355d26c2c1.tar.gz
adopted and updated PKGBUILD
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD17
2 files changed, 14 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 06cf0a684c79..2becf81021eb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,8 @@
-# Generated by mksrcinfo v8
-# Sat Sep 3 23:56:07 UTC 2016
pkgbase = mate-tweak-git
pkgdesc = MATE desktop tweak tool
- pkgver = 16.10.5.r3.bb8c682
+ pkgver = 18.04.13.r3.gad32cf9
pkgrel = 1
- url = https://bitbucket.org/ubuntu-mate/mate-tweak
+ url = https://github.com/ubuntu-mate/mate-tweak
arch = any
license = GPL
makedepends = git
@@ -25,7 +23,6 @@ pkgbase = mate-tweak-git
optdepends = docky
optdepends = synapse
optdepends = topmenu-gtk
- optdepends = gnome-main-menu
optdepends = mate-menu
optdepends = mate-netbook
optdepends = mate-applet-dock-git
@@ -33,10 +30,10 @@ pkgbase = mate-tweak-git
optdepends = compiz
provides = mate-tweak
conflicts = mate-tweak
- source = mate-tweak::git+https://bitbucket.org/ubuntu-mate/mate-tweak.git
+ source = mate-tweak::git+https://github.com/ubuntu-mate/mate-tweak.git
source = ubuntu-mate-settings::bzr+lp:~ubuntu-mate-dev/ubuntu-mate/ubuntu-mate-settings
- md5sums = SKIP
- md5sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
pkgname = mate-tweak-git
diff --git a/PKGBUILD b/PKGBUILD
index 3ced4e66c2e1..777328d8cc24 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,24 @@
-# Maintainer: Tom < reztho at archlinux dot us >
+# Maintainer: Frederic Bezies < fredbezies at gmail dot com >
+# Contributor: Tom < reztho at archlinux dot us >
pkgname=mate-tweak-git
-pkgver=16.10.5.r3.bb8c682
+pkgver=18.04.13.r3.gad32cf9
pkgrel=1
pkgdesc="MATE desktop tweak tool"
arch=('any')
-url="https://bitbucket.org/ubuntu-mate/mate-tweak"
+url="https://github.com/ubuntu-mate/mate-tweak"
license=('GPL')
depends=('python' 'gtk3' 'dconf' 'gdk-pixbuf2' 'libnotify' 'python-gobject' 'python-psutil' 'python-configobj' 'mesa-demos' 'python-setproctitle')
-optdepends=('plank' 'docky' 'synapse' 'topmenu-gtk' 'gnome-main-menu' 'mate-menu' 'mate-netbook' 'mate-applet-dock-git' 'mutter' 'compiz')
+optdepends=('plank' 'docky' 'synapse' 'topmenu-gtk' 'mate-menu' 'mate-netbook' 'mate-applet-dock-git' 'mutter' 'compiz')
makedepends=('git' 'bzr' 'python-setuptools' 'python-distutils-extra')
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
-source=('mate-tweak::git+https://bitbucket.org/ubuntu-mate/mate-tweak.git'
- 'ubuntu-mate-settings::bzr+lp:~ubuntu-mate-dev/ubuntu-mate/ubuntu-mate-settings')
-md5sums=('SKIP' 'SKIP')
+source=('mate-tweak::git+https://github.com/ubuntu-mate/mate-tweak.git'
+ 'ubuntu-mate-settings::bzr+lp:~ubuntu-mate-dev/ubuntu-mate/ubuntu-mate-settings')
+sha256sums=('SKIP' 'SKIP')
pkgver() {
cd "$srcdir/${pkgname%-git}"
- printf "%s" "$(git describe --long | sed 's/\([^-]*-\)g/r\1/;s/-/./g')"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
prepare() {