summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorreztho2016-03-20 15:04:27 +0000
committerreztho2016-03-20 15:04:27 +0000
commitf0a2fbe7e3e2853d6b8393cbe1b86e0029125e81 (patch)
tree23f8769c9dfc362d77c0dd71571aba15497670c9
parent4f08f097ab7ee718b242a9a32e2646bdfa48bb17 (diff)
downloadaur-f0a2fbe7e3e2853d6b8393cbe1b86e0029125e81.tar.gz
Improved the package
1. Fixed the dependencies (hopefully) 2. Added extra panels from the ubuntu-mate-default-settings package
-rw-r--r--.SRCINFO26
-rw-r--r--PKGBUILD32
2 files changed, 42 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3d21c55519c4..07484f828c8b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,8 @@
+# Generated by mksrcinfo v8
+# Sun Mar 20 15:02:44 UTC 2016
pkgbase = mate-tweak-git
- pkgdesc = Mate desktop configuration tool
- pkgver = 3.5.2a.r0.8df794d
+ pkgdesc = MATE desktop tweak tool
+ pkgver = 3.5.8.r0.8a5299d
pkgrel = 1
url = https://bitbucket.org/ubuntu-mate/mate-tweak
arch = any
@@ -9,12 +11,28 @@ pkgbase = mate-tweak-git
makedepends = python-setuptools
makedepends = python-distutils-extra
depends = python
- depends = wmctrl
- depends = python-configobj
+ depends = gtk3
+ depends = dconf
+ depends = gdk-pixbuf2
+ depends = libnotify
depends = python-gobject
+ depends = python-psutil
+ depends = python-configobj
+ optdepends = plank
+ optdepends = docky
+ optdepends = synapse
+ optdepends = topmenu-gtk
+ optdepends = gnome-main-menu
+ optdepends = mate-menu
+ optdepends = mate-netbook
+ optdepends = mate-applet-dock-git
+ optdepends = mutter
+ optdepends = compiz
provides = mate-tweak
conflicts = mate-tweak
source = mate-tweak::git+https://bitbucket.org/ubuntu-mate/mate-tweak.git
+ source = ubuntu-mate-settings::bzr+lp:~ubuntu-mate-dev/ubuntu-mate/ubuntu-mate-settings
+ md5sums = SKIP
md5sums = SKIP
pkgname = mate-tweak-git
diff --git a/PKGBUILD b/PKGBUILD
index 5f022975e58c..f83d881e9fd5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,35 @@
# Maintainer: Tom < reztho at archlinux dot us >
pkgname=mate-tweak-git
-pkgver=3.5.2a.r0.8df794d
+pkgver=3.5.8.r0.8a5299d
pkgrel=1
-pkgdesc="Mate desktop configuration tool"
+pkgdesc="MATE desktop tweak tool"
arch=('any')
url="https://bitbucket.org/ubuntu-mate/mate-tweak"
license=('GPL')
-depends=('python' 'wmctrl' 'python-configobj' 'python-gobject')
+depends=('python' 'gtk3' 'dconf' 'gdk-pixbuf2' 'libnotify' 'python-gobject' 'python-psutil' 'python-configobj')
+optdepends=('plank' 'docky' 'synapse' 'topmenu-gtk' 'gnome-main-menu' 'mate-menu' 'mate-netbook' 'mate-applet-dock-git' 'mutter' 'compiz')
makedepends=('git' 'python-setuptools' 'python-distutils-extra')
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
-source=('mate-tweak::git+https://bitbucket.org/ubuntu-mate/mate-tweak.git')
-md5sums=('SKIP')
+source=('mate-tweak::git+https://bitbucket.org/ubuntu-mate/mate-tweak.git'
+ 'ubuntu-mate-settings::bzr+lp:~ubuntu-mate-dev/ubuntu-mate/ubuntu-mate-settings')
+md5sums=('SKIP' 'SKIP')
pkgver() {
- cd "$srcdir/${pkgname%-git}"
- printf "%s" "$(git describe --long | sed 's/\([^-]*-\)g/r\1/;s/-/./g')"
+ cd "$srcdir/${pkgname%-git}"
+ printf "%s" "$(git describe --long | sed 's/\([^-]*-\)g/r\1/;s/-/./g')"
}
-package() {
- cd "$srcdir/${pkgname%-git}"
- /usr/bin/python setup.py install --root="$pkgdir/" --optimize=1
+prepare() {
+ cd "$srcdir/${pkgname%-git}"
+ sed -i 's@/usr/lib/mate-applets/topmenu-mate-panel-applet@/usr/lib/topmenu-gtk/topmenu-mate-panel-applet@' ./mate-tweak
+}
- cd "$pkgdir"
- sed -i 's@/usr/bin/python2@/usr/bin/python@' usr/bin/mate-tweak
+package() {
+ cd "$srcdir/${pkgname%-git}"
+ python setup.py install --root="$pkgdir/" --optimize=1
+
+ # Extra layouts from the ubuntu-mate-default-settings package
+ install -d "$pkgdir/usr/share/mate-panel/layouts/"
+ install -m644 "$srcdir/ubuntu-mate-settings/usr/share/mate-panel/layouts/"* "$pkgdir/usr/share/mate-panel/layouts/"
}