summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorIKRadulov2017-05-19 12:36:15 +0300
committerIKRadulov2017-05-19 12:36:15 +0300
commit9fd94427a8f7cd15fd262a029901be822ac5e6df (patch)
tree5aa4937111ca7b3ade3776196ad1d3e3a1d963b8
downloadaur-9fd94427a8f7cd15fd262a029901be822ac5e6df.tar.gz
initial commit
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD29
2 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..28d97466590e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = mate-window-applets
+ pkgver = 1.3.2
+ pkgrel = 1
+ url = https://github.com/IKRadulov/mate-window-applets
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = automake
+ makedepends = autoconf
+ makedepends = gettext
+ makedepends = gobject-introspection
+ depends = python
+ depends = gettext
+ depends = gobject-introspection
+ depends = mate-panel
+ source = https://github.com/IKRadulov/mate-window-applets/archive/1.3.2.tar.gz
+ sha256sums = 061ac44c1dcd16b3feb663dd753c9557d046de98ae4edad80cad37aceff82af1
+
+pkgname = mate-window-applets
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..399fb097f649
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+url="https://github.com/IKRadulov/mate-window-applets"
+license=('GPL3')
+
+pkgname="mate-window-applets"
+pkgver=1.3.2
+pkgrel=1
+arch=('i686' 'x86_64')
+makedepends=('automake' 'autoconf' 'gettext' 'gobject-introspection')
+depends=('python' 'gettext' 'gobject-introspection' 'mate-panel')
+source=("https://github.com/IKRadulov/${pkgname}/archive/${pkgver}.tar.gz")
+sha256sums=('061ac44c1dcd16b3feb663dd753c9557d046de98ae4edad80cad37aceff82af1')
+
+build()
+{
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ NOCONFIGURE=1 ./autogen.sh
+ ./configure --prefix=/usr --disable-schemas-compile
+
+ make
+
+}
+
+package_mate-window-applets() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make DESTDIR="${pkgdir}" install
+ ./install-icons.sh "${pkgdir}/usr/share" install
+}
+