summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorIKRadulov2017-09-08 12:43:59 +0300
committerIKRadulov2017-09-08 12:43:59 +0300
commite52b3073d8e095602e62b444b74def261f99be7b (patch)
tree686913e9d95147973bd4654efa6bcae6ac26cd42
parent9fd94427a8f7cd15fd262a029901be822ac5e6df (diff)
downloadaur-e52b3073d8e095602e62b444b74def261f99be7b.tar.gz
update
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD60
2 files changed, 55 insertions, 24 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 28d97466590e..5a59d9a8dce7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,19 @@
pkgbase = mate-window-applets
- pkgver = 1.3.2
+ pkgver = 1.4.1
pkgrel = 1
url = https://github.com/IKRadulov/mate-window-applets
arch = i686
arch = x86_64
license = GPL3
- makedepends = automake
- makedepends = autoconf
- makedepends = gettext
- makedepends = gobject-introspection
- depends = python
- depends = gettext
- depends = gobject-introspection
+ makedepends = meson
+ makedepends = ninja
+ makedepends = vala
+ depends = gtk3
+ depends = gdk-pixbuf2
+ depends = libwnck3
depends = mate-panel
- source = https://github.com/IKRadulov/mate-window-applets/archive/1.3.2.tar.gz
- sha256sums = 061ac44c1dcd16b3feb663dd753c9557d046de98ae4edad80cad37aceff82af1
+ source = git+https://github.com/IKRadulov/mate-window-applets
+ sha256sums = SKIP
pkgname = mate-window-applets
diff --git a/PKGBUILD b/PKGBUILD
index 399fb097f649..ad2966577af5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,61 @@
+pkgname="mate-window-applets"
url="https://github.com/IKRadulov/mate-window-applets"
license=('GPL3')
+arch=('i686' 'x86_64')
+pkgver=1.4.1
+
+_disable_buttons=0
+_disable_menu=0
+_disable_title=0
+
+_opts=()
+
+if (("${_disable_buttons}" == 0));then
+ _opts+=(-D build-window-buttons=true)
+ msg "Building with buttons"
+else
+ _opts+=(-D build-window-buttons=false)
+fi
+
+if (("${_disable_menu}" == 0));then
+ _opts+=(-D build-window-menu=true)
+ msg "Building with menu"
+else
+ _opts+=(-D build-window-menu=false)
+fi
+
+if (("${_disable_title}" == 0));then
+ _opts+=(-D build-window-title=true)
+ msg "Building with title"
+else
+ _opts+=(-D build-window-title=false)
+fi
-pkgname="mate-window-applets"
-pkgver=1.3.2
pkgrel=1
-arch=('i686' 'x86_64')
-makedepends=('automake' 'autoconf' 'gettext' 'gobject-introspection')
-depends=('python' 'gettext' 'gobject-introspection' 'mate-panel')
-source=("https://github.com/IKRadulov/${pkgname}/archive/${pkgver}.tar.gz")
-sha256sums=('061ac44c1dcd16b3feb663dd753c9557d046de98ae4edad80cad37aceff82af1')
+
+makedepends=('meson' 'ninja' 'vala')
+depends=('gtk3' 'gdk-pixbuf2' 'libwnck3' 'mate-panel')
+source=("git+https://github.com/IKRadulov/${pkgname}")
+sha256sums=('SKIP')
build()
{
- cd "${srcdir}/${pkgname}-${pkgver}"
+ cd "${srcdir}/${pkgname}"
+
+ meson --prefix /usr --buildtype=plain build
- NOCONFIGURE=1 ./autogen.sh
- ./configure --prefix=/usr --disable-schemas-compile
+ cd build
- make
+ meson configure "${_opts[@]}"
+
+ ninja
+ msg "If you want to disable an applet, edit pkgbuild variables _disable_[applet]"
}
package_mate-window-applets() {
- cd "${srcdir}/${pkgname}-${pkgver}"
- make DESTDIR="${pkgdir}" install
+ cd "${srcdir}/${pkgname}/build"
+ DESTDIR="${pkgdir}" ninja install
+ cd ..
./install-icons.sh "${pkgdir}/usr/share" install
}
-