summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlelgenio2019-09-21 03:59:23 -0300
committerlelgenio2019-09-21 03:59:23 -0300
commit6f8a433a473f87e6a8876ed09f305d0b64d6ccfc (patch)
tree2bbbccd297ee1efb692dde97bd06b7b7cee3e49d
downloadaur-6f8a433a473f87e6a8876ed09f305d0b64d6ccfc.tar.gz
first commit
-rw-r--r--.SRCINFO26
-rw-r--r--99-gdm-use-materia-theme.hook13
-rw-r--r--PKGBUILD55
-rw-r--r--colors7
-rw-r--r--colors-dark7
5 files changed, 108 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..58ca2f7914e2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,26 @@
+pkgbase = materia-custom-accent
+ pkgdesc = Easy installer for the materia theme with a custom accent color, gdm and qt5 support and a workaround for dark apps (edit PKGBUILD)
+ pkgver = r1165.9940151d
+ pkgrel = 1
+ url = http://github.com/nana-4/materia-theme
+ arch = any
+ license = GPL
+ depends = gtk3>=3.22
+ depends = gtk-engine-murrine
+ depends = gnome-themes-extra
+ depends = kvantum-qt5
+ conflicts = materia-theme
+ conflicts = kvantum-theme-materia
+ source = materia-theme::git+http://github.com/nana-4/materia-theme.git
+ source = materia-theme-qt::git+http://github.com/PapirusDevelopmentTeam/materia-kde.git
+ source = colors
+ source = colors-dark
+ source = 99-gdm-use-materia-theme.hook
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = 6cbc8dee30cb20f6124e5d1c2816be694322733d8058b014fa2280879c0f520f
+ sha256sums = 747579f23f1eb7d482ef78e6f2b17f33695405017c1029e845d07381a3dd2509
+ sha256sums = 7db390763b37c3cc2c2984a8a3e8452d1822ac579def6a07eecbee076fb73d77
+
+pkgname = materia-custom-accent
+
diff --git a/99-gdm-use-materia-theme.hook b/99-gdm-use-materia-theme.hook
new file mode 100644
index 000000000000..ba2b625c15ca
--- /dev/null
+++ b/99-gdm-use-materia-theme.hook
@@ -0,0 +1,13 @@
+[Trigger]
+Operation = Upgrade
+Operation = Install
+Type = Package
+Target = gnome-shell
+Target = materia-custom-accent
+
+[Action]
+Description = Replace GDM theme with Materia with custom accent
+When = PostTransaction
+Exec = /usr/bin/sh -c "cd /usr/share/themes/materia-custom-accent/gnome-shell && glib-compile-resources --target=/usr/share/gnome-shell/gnome-shell-theme.gresource gnome-shell-theme.gresource.xml"
+Depends = bash
+Depends = glib2
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ebab5d5bce75
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,55 @@
+# Maintainer: Leonardo Eugenio <lelgenio@disroot.org>
+pkgname=materia-custom-accent
+_pkgname=materia-theme
+_accent=c85a5a
+pkgdesc="Easy installer for the materia theme with a custom accent color, gdm and qt5 support and a workaround for dark apps (edit PKGBUILD)"
+arch=('any')
+url="http://github.com/nana-4/materia-theme"
+_url_qt="http://github.com/PapirusDevelopmentTeam/materia-kde"
+pkgver=r1165.9940151d
+pkgrel=1
+license=('GPL')
+makedepends=()
+depends=('gtk3>=3.22' 'gtk-engine-murrine' 'gnome-themes-extra' 'kvantum-qt5')
+optdepends=()
+provides=()
+conflicts=('materia-theme' 'kvantum-theme-materia')
+replaces=()
+source=(${_pkgname}::git+$url.git
+ ${_pkgname}-qt::git+$_url_qt.git
+ colors
+ colors-dark
+ 99-gdm-use-materia-theme.hook)
+sha256sums=('SKIP'
+ 'SKIP'
+ '6cbc8dee30cb20f6124e5d1c2816be694322733d8058b014fa2280879c0f520f'
+ '747579f23f1eb7d482ef78e6f2b17f33695405017c1029e845d07381a3dd2509'
+ '7db390763b37c3cc2c2984a8a3e8452d1822ac579def6a07eecbee076fb73d77')
+pkgver() {
+ cd "${srcdir}/${_pkgname}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+prepare(){
+ cd "${srcdir}"
+ sed "s/MY-COLOR/$_accent/" -i colors colors-dark
+
+ cd materia-theme-qt/Kvantum
+ sed "s/4285f4/$_accent/" -i */*
+}
+build(){
+ cd "${srcdir}/${_pkgname}"
+ ./change_color.sh -t "${srcdir}/themes" -o $pkgname "${srcdir}/colors"
+ ./change_color.sh -t "${srcdir}/themes" -o $pkgname-dark "${srcdir}/colors-dark"
+
+ cp "${srcdir}/themes/$pkgname-dark/gtk-3.0/gtk.css" \
+ "${srcdir}/themes/$pkgname/gtk-3.0/gtk-dark.css"
+}
+package() {
+ mkdir -p "${pkgdir}/usr/share/themes"
+ cp -r "${srcdir}"/themes/* "${pkgdir}/usr/share/themes"
+ cp -r "${srcdir}"/materia-theme-qt/Kvantum "${pkgdir}/usr/share"
+
+ mkdir -p "${pkgdir}/usr/share/libalpm/hooks"
+ cp 99-gdm-use-materia-theme.hook "${pkgdir}/usr/share/libalpm/hooks"
+}
+
diff --git a/colors b/colors
new file mode 100644
index 000000000000..15ea77164b1f
--- /dev/null
+++ b/colors
@@ -0,0 +1,7 @@
+SEL_BG=MY-COLOR
+FG=212121
+BG=eeeeee
+HDR_FG=eeeeee
+HDR_BG=303030
+MATERIA_VIEW=ffffff
+MATERIA_SURFACE=fafafa
diff --git a/colors-dark b/colors-dark
new file mode 100644
index 000000000000..0567354a945a
--- /dev/null
+++ b/colors-dark
@@ -0,0 +1,7 @@
+SEL_BG=MY-COLOR
+FG=eeeeee
+BG=212121
+HDR_FG=e0e0e0
+HDR_BG=212121
+MATERIA_VIEW=303030
+MATERIA_SURFACE=424242