summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCrewmate2021-05-01 23:37:22 -0700
committerCrewmate2021-05-01 23:37:22 -0700
commitec02f40e765bf704bcbb537bdee4fbc5caab3d86 (patch)
treecb6ca23e625cc49d169b5fb42ceb0ce5482ff636
downloadaur-ec02f40e765bf704bcbb537bdee4fbc5caab3d86.tar.gz
first commit
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD36
-rw-r--r--remove-npm-install-from-meson-build.patch13
3 files changed, 72 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3328300561b8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = materia-transparent-gtk-theme-git
+ pkgdesc = A Transparent Material Design theme for GNOME/GTK+ based desktop environments
+ pkgver = 85bdc29
+ pkgrel = 2
+ arch = any
+ license = GPL
+ makedepends = meson
+ makedepends = npm
+ makedepends = gtk3
+ makedepends = gtk4
+ makedepends = gnome-shell
+ depends = gnome-themes-extra
+ optdepends = gtk-engine-murrine: for gtk2 theme
+ provides = materia-theme
+ conflicts = materia-theme
+ replaces = materia-theme
+ source = git+https://github.com/ckissane/materia-theme-transparent#commit=85bdc29
+ source = remove-npm-install-from-meson-build.patch
+ md5sums = SKIP
+ md5sums = SKIP
+
+pkgname = materia-transparent-gtk-theme-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f4a06c18cd41
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer Crewmate <sus@morshu.xyz>
+pkgname=materia-transparent-gtk-theme-git
+pkgver=85bdc29
+pkgrel=2
+pkgdesc="A Transparent Material Design theme for GNOME/GTK+ based desktop environments"
+arch=(any)
+license=(GPL)
+depends=(gnome-themes-extra)
+makedepends=(meson npm gtk3 gtk4 gnome-shell)
+optdepends=('gtk-engine-murrine: for gtk2 theme')
+provides=(materia-theme)
+conflicts=(materia-theme)
+replaces=(materia-theme)
+source=(
+ "git+https://github.com/ckissane/materia-theme-transparent#commit=85bdc29"
+ remove-npm-install-from-meson-build.patch
+)
+md5sums=(
+ "SKIP"
+ "SKIP"
+)
+
+prepare() {
+ cd materia-theme-transparent
+ patch -Np1 < ${srcdir}/remove-npm-install-from-meson-build.patch
+ npm install --cache ${srcdir}/npm-cache
+}
+
+build() {
+ arch-meson materia-theme-transparent build
+ meson compile -C build
+}
+
+package() {
+ DESTDIR="${pkgdir}" meson install -C build
+}
diff --git a/remove-npm-install-from-meson-build.patch b/remove-npm-install-from-meson-build.patch
new file mode 100644
index 000000000000..48cdc231e97d
--- /dev/null
+++ b/remove-npm-install-from-meson-build.patch
@@ -0,0 +1,13 @@
+diff --git a/meson.build b/meson.build
+index 3928f9c2..e2be180f 100644
+--- a/meson.build
++++ b/meson.build
+@@ -27,9 +27,6 @@ if sass.found()
+ endif
+
+ if not sass.found() or sass_is_ruby_sass or not sass_has_module_system
+- message('dart-sass >= 1.23.0 not found, installing it locally via npm')
+- npm = find_program('npm')
+- run_command(npm, 'install')
+ sass = find_program('./node_modules/.bin/sass')
+ endif