summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFrederik Enste2020-04-19 00:38:19 +0200
committerFrederik Enste2020-04-19 00:38:19 +0200
commit19dd4713cc346dd51f9978fdd0750aea46b054d2 (patch)
tree4180b84b0a92f67fd7eab05a205bf71651b89de9
parent5e7024ba94e304e2b23bf6c4bf49349e15870df7 (diff)
downloadaur-19dd4713cc346dd51f9978fdd0750aea46b054d2.tar.gz
added materialize software
-rw-r--r--.SRCINFO28
-rw-r--r--.gitignore7
-rw-r--r--PKGBUILD113
-rw-r--r--materialize-bin.desktop12
-rw-r--r--materialize-bin.install14
-rwxr-xr-xmaterialize-bin.sh20
6 files changed, 105 insertions, 89 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a7b8024e9c67..b01a63d1e305 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,24 @@
-pkgbase = pkgbase
- pkgdesc = Japanese-Russian kanji and word dictionary
- pkgver = 1.10
+pkgbase = materialize-bin
+ pkgdesc = Image to Material tool (uses Wine).
+ pkgver = 1.78
pkgrel = 1
- url = http://www.susi.ru/yarxi/
+ url = http://boundingboxsoftware.com/index.html
+ install = materialize-bin.install
arch = x86_64
- license = custom
- depends = ttf-sazanami
- depends = nas
+ license = GNU
+ license = custom:GNU General Public License v3.0
+ makedepends = unzip
+ depends = wine
+ depends = winetricks
+ depends = desktop-file-utils
+ source = http://boundingboxsoftware.com/materialize/download/Materialize_1.78.zip
+ source = https://raw.githubusercontent.com/BoundingBoxSoftware/Materialize/master/LICENSE
+ source = materialize-bin.sh
+ source = materialize-bin.desktop
+ sha256sums = b0f6e3a905781e85dcd7db2383646bce51b8984ab93d1e3d13be42d5bea8904a
+ sha256sums = 3972dc9744f6499f0f9b2dbf76696f2ae7ad8af9b23dde66d6af86c9dfb36986
+ sha256sums = ed9dcdab4071a854a460bfa56a79738895e2ca6cd7641d1928d160984c0619bd
+ sha256sums = d1247c77728c389d385c7c830802d9bcbb1c20be9b98136b815188c8c3d79cbe
-pkgname = yarxi
+pkgname = materialize-bin
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f4d317011cac
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+*
+!.gitignore
+!PKGBUILD
+!.SRCINFO
+!materialize-bin.sh
+!materialize-bin.install
+!materialize-bin.desktop \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
index e21a86c2f396..bb89905ac47d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,89 +1,40 @@
-# Maintainer Seva Alekseyev <sevaa@yarxi.ru>
-# Maintainer Stoyan Minaev <stoyan.minaev@gmail.com>
+# Maintainer: Frederik Enste <frederik at fenste dot de>
+# Maintainer: t00manysecrets <frederik at fenste dot de>
-pkgbase=pkgbase
-pkgname=yarxi
-pkgver=1.10
+pkgname=materialize-bin
+pkgver=1.78
pkgrel=1
-pkgdesc="Japanese-Russian kanji and word dictionary"
-url="http://www.susi.ru/yarxi/"
-license=('custom')
-_source=(
- "http://www.susi.ru/yarxi/yarxi_${pkgver}-${pkgrel}_amd64.deb"
- "http://ftp.uk.debian.org/debian/pool/main/q/qt4-x11/libqtcore4_4.8.7+dfsg-11_amd64.deb"
- "http://ftp.uk.debian.org/debian/pool/main/q/qt4-x11/libqtgui4_4.8.7+dfsg-11_amd64.deb"
- "http://ftp.uk.debian.org/debian/pool/main/q/qt4-x11/libqt4-network_4.8.7+dfsg-11_amd64.deb"
-)
-arch=('x86_64')
-_md5sums=(
- '812d2265816ed781751c5c0eb6664d91'
- 'b243ada8569b2b3d4586dc4178fd8d56'
- '797e351a57c9d56368f710e7cba40f21'
- 'b3cff12767e21d3a76794046557d3df0'
-)
-depends=(
- ttf-sazanami nas
-)
-
-prepare() {
- cd $srcdir/
- echo "Due to 'makepkg' and 'PKGBUILD' specs limitations I need to dowanload sources and validate them by myself"
- for source_url in ${_source[@]}; do
- source_filename=${source_url##*/}
- if [ ! -f "$source_filename" ]; then
- echo "Downloading next source - $source_filename ..."
- curl -A DUMMY -O "$source_url";
- else
- echo "Found already downloaded source - $source_filename"
- fi
- done
- echo "And now we must validated dowanloaded sources ..."
- for (( i=0; i<${#_source[@]}; ++i )); do
- source_url=${_source[i]}
- source_filename=${source_url##*/}
- source_expected_md5sum=${_md5sums[i]}
- source_actual_md5sum=$(md5sum $source_filename | awk '{print $1}')
- if [ "$source_actual_md5sum" == "$source_expected_md5sum" ]; then
- echo "Validated next source - $source_filename"
- else
- echo "Found corrupted source - $source_filename"; return 1
- fi
- done
-}
+pkgdesc="Image to Material tool (uses Wine)."
+arch=(x86_64)
+url="http://boundingboxsoftware.com/index.html"
+license=('GNU' 'custom:GNU General Public License v3.0')
+depends=(wine winetricks desktop-file-utils)
+makedepends=(unzip)
+source=("http://boundingboxsoftware.com/materialize/download/Materialize_${pkgver}.zip"
+ "https://raw.githubusercontent.com/BoundingBoxSoftware/Materialize/master/LICENSE"
+ "${pkgname}.sh"
+ "${pkgname}.desktop")
+install="${pkgname}.install"
+sha256sums=('b0f6e3a905781e85dcd7db2383646bce51b8984ab93d1e3d13be42d5bea8904a'
+ '3972dc9744f6499f0f9b2dbf76696f2ae7ad8af9b23dde66d6af86c9dfb36986'
+ 'ed9dcdab4071a854a460bfa56a79738895e2ca6cd7641d1928d160984c0619bd'
+ 'd1247c77728c389d385c7c830802d9bcbb1c20be9b98136b815188c8c3d79cbe')
build() {
- cd $srcdir/
- mkdir -p deb/{$pkgname,qt4core,qt4gui,qt4network}
- bsdtar xf yarxi_${pkgver}-${pkgrel}_amd64.deb -C deb/$pkgname/
- bsdtar xf libqtcore4_4.8.7+dfsg-11_amd64.deb -C deb/qt4core/
- bsdtar xf libqtgui4_4.8.7+dfsg-11_amd64.deb -C deb/qt4gui/
- bsdtar xf libqt4-network_4.8.7+dfsg-11_amd64.deb -C deb/qt4network/
- for dir in deb/$pkgname deb/qt4core deb/qt4gui deb/qt4network; do
- cd $dir; tar xf data.tar.*; cd $srcdir
- done
+ # unpack the zip file (into Materialize_Data)
+ unzip -o Materialize_${pkgver}.zip -d materialize
}
package() {
- cd $srcdir/
- mkdir -p $pkgdir/usr/lib/
- mkdir -p $pkgdir/usr/bin/
- mkdir -p $pkgdir/usr/share/
- mkdir -p $pkgdir/usr/share/applications/
- mkdir -p $pkgdir/usr/share/doc/$pkgname/
- mkdir -p $pkgdir/usr/share/icons/hicolor/{16x16/apps,32x32/apps,48x48/apps}/
- mkdir -p $pkgdir/usr/share/pixmaps/
- mkdir -p $pkgdir/usr/share/$pkgname/
- install -m 0755 $srcdir/deb/$pkgname/usr/bin/$pkgname $pkgdir/usr/bin/$pkgname
- install -m 0755 $srcdir/deb/qt4core/usr/lib/x86_64-linux-gnu/libQtCore.so.4.8.7 $pkgdir/usr/lib/libQtCore.so.4
- install -m 0755 $srcdir/deb/qt4gui/usr/lib/x86_64-linux-gnu/libQtGui.so.4.8.7 $pkgdir/usr/lib/libQtGui.so.4
- install -m 0755 $srcdir/deb/qt4network/usr/lib/x86_64-linux-gnu/libQtNetwork.so.4.8.7 $pkgdir/usr/lib/libQtNetwork.so.4
- install -m 0644 $srcdir/deb/$pkgname/usr/share/applications/seva-yarxi.desktop $pkgdir/usr/share/applications/
- install -m 0644 $srcdir/deb/$pkgname/usr/share/doc/$pkgname/copyright $pkgdir/usr/share/doc/$pkgname/
- for icons in 16x16 32x32 48x48; do
- install -m 0644 $srcdir/deb/$pkgname/usr/share/icons/hicolor/$icons/apps/seva-yarxi.png $pkgdir/usr/share/icons/hicolor/$icons/apps/
- done
- install -m 0644 $srcdir/deb/$pkgname/usr/share/pixmaps/*.xpm $pkgdir/usr/share/pixmaps/
- install -m 0644 $srcdir/deb/$pkgname/usr/share/$pkgname/yarxice.db $pkgdir/usr/share/$pkgname/
-}
+ # install program into destination
+ mkdir -p "${pkgdir}/opt/${pkgname}"
+ cp -r ${srcdir}/materialize/* "${pkgdir}/opt/${pkgname}"
+ chown root:root "${pkgdir}/opt/${pkgname}"
+ chmod -R 755 "${pkgdir}/opt/${pkgname}"
-#vim: syntax=sh
+ # install license
+ install -Dm644 "${srcdir}/LICENSE" "${pkgdir}/usr/share/license/${pkgname}/LICENSE"
+
+ # install start script
+ install -Dm755 "${srcdir}/${pkgname}.sh" "${pkgdir}/usr/bin/${pkgname}"
+}
diff --git a/materialize-bin.desktop b/materialize-bin.desktop
new file mode 100644
index 000000000000..5dff26cc5d6c
--- /dev/null
+++ b/materialize-bin.desktop
@@ -0,0 +1,12 @@
+[Desktop Entry]
+Name=Materialize
+GenericName=3D Material Tool
+Comment=Image to Material Tool
+Encoding=UTF-8
+Version=1.78
+Type=Application
+Terminal=false
+Icon=foobar2000
+Exec=materialize-bin
+Categories=Utility;Game
+StartupWMClass=Materialize.exe \ No newline at end of file
diff --git a/materialize-bin.install b/materialize-bin.install
new file mode 100644
index 000000000000..cfd4e9fc977e
--- /dev/null
+++ b/materialize-bin.install
@@ -0,0 +1,14 @@
+post_install() {
+ update-desktop-database -q /usr/share/applications
+ echo 'Please execute "materialize-bin --init" afterwards to initialize the wineprefix'
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+post_remove() {
+ post_install $1
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/materialize-bin.sh b/materialize-bin.sh
new file mode 100755
index 000000000000..3a376d3f3b6e
--- /dev/null
+++ b/materialize-bin.sh
@@ -0,0 +1,20 @@
+#! /bin/bash
+set -e
+
+arg=$1
+
+if [[ "${arg}" == "--init" ]]; then
+ echo "Initializing wineprefixe for materialize..."
+ echo 'If the initialization failes run "winetricks prefix=materialize-bin annihilate" and rerun "materialize-bin --init"'
+ echo ' '
+ echo ' '
+ winetricks -q prefix=materialize-bin arch=64 vcrun2019 corefonts
+ exit 0
+elif [[ -z "${arg}" ]]; then
+ cd "/opt/materialize-bin"
+ WINEPREFIX="$HOME/.local/share/wineprefixes/materialize-bin" wine Materialize.exe
+ exit $?
+fi
+
+echo "Unexpected argument."
+echo "Use --init to initialize the wineprefix or none to start the program." \ No newline at end of file