summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWilliam J. Bowman2019-06-29 21:38:11 -0700
committerWilliam J. Bowman2019-06-29 21:57:39 -0700
commit2300c023891636d851186ef571d5eda92c8eb315 (patch)
treeaa85c76949a2afe426a106cb5c3d2875a1dbd9ca
parent4e3d56caa3d1ad1c26b43978b6b51d3fcba72f77 (diff)
downloadaur-2300c023891636d851186ef571d5eda92c8eb315.tar.gz
Updated to 1.9.0-1
* Removed manual setting of -j; that should be done by makepkg.conf * Trying to use globbing for annoying folder tag
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD18
2 files changed, 14 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 48e65a7c30a8..574b3515d34c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,16 @@
pkgbase = mathcomp
pkgdesc = The entire mathematical components library for Coq.
- pkgver = 1.7.0
+ pkgver = 1.9.0
pkgrel = 1
url = https://math-comp.github.io/math-comp/
arch = i686
arch = x86_64
license = GPL
- depends = coq>=8.6
- depends = coq<=8.8
- source = mathcomp-1.7.0.tar.gz::https://github.com/math-comp/math-comp/tarball/mathcomp-1.7.0
- sha256sums = 2d30a244769f3c7d628bff2f9118df935cd99dad774842b0e9d35bafdb3e02ea
- sha512sums = 332f79e97cc3a0fe72cff7e96080c34d5de11ff2c86bf1f4ed4953457cb3cd36795502e4fed24dec698492419076acd97571c154d946ba91b02ad27389423a61
+ depends = coq>=8.7
+ conflicts = ssreflect
+ source = mathcomp-1.9.0.tar.gz::https://github.com/math-comp/math-comp/tarball/mathcomp-1.9.0
+ sha256sums = 0c9a7f8ffc4166a78141f72756f72eb739d6d2824654ef0cc34b2d8cea77a540
+ sha512sums = 2ed88d8302be7279e30bc17636cdcf059f3c08d900e0734fb2dc351b8003ec2ae645bcbb6d9ee89bc342ae9176a114291f36772fe930af1528a7d0171c16b7f4
pkgname = mathcomp
diff --git a/PKGBUILD b/PKGBUILD
index 4b0e70b5c3a8..93afefc21270 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,28 +1,26 @@
# Maintainer: William J. Bowman <aur@williamjbowman.com>
pkgname=mathcomp
-pkgver=1.7.0
+pkgver=1.9.0
pkgrel=1
-# sigh. they rename the folder based on the commit hash, and glob matching can cause errors
-_pkgcommitid=591c3e4
pkgdesc="The entire mathematical components library for Coq."
url="https://math-comp.github.io/math-comp/"
arch=('i686' 'x86_64')
license=('GPL')
-depends=('coq>=8.6' 'coq<=8.8')
+depends=('coq>=8.7')
source=(mathcomp-$pkgver.tar.gz::https://github.com/math-comp/math-comp/tarball/mathcomp-$pkgver)
-sha256sums=('2d30a244769f3c7d628bff2f9118df935cd99dad774842b0e9d35bafdb3e02ea')
-sha512sums=('332f79e97cc3a0fe72cff7e96080c34d5de11ff2c86bf1f4ed4953457cb3cd36795502e4fed24dec698492419076acd97571c154d946ba91b02ad27389423a61')
+sha256sums=('0c9a7f8ffc4166a78141f72756f72eb739d6d2824654ef0cc34b2d8cea77a540')
+sha512sums=('2ed88d8302be7279e30bc17636cdcf059f3c08d900e0734fb2dc351b8003ec2ae645bcbb6d9ee89bc342ae9176a114291f36772fe930af1528a7d0171c16b7f4')
+conflicts=('ssreflect')
build() {
- cd $srcdir/math-comp-math-comp-${_pkgcommitid}/$pkgname
+ cd $srcdir/math-comp-math-comp-*/$pkgname
- # Per recommendations from README, use -j 3
- make -j 3
+ make
}
package(){
- cd $srcdir/math-comp-math-comp-${_pkgcommitid}/$pkgname
+ cd $srcdir/math-comp-math-comp-*/$pkgname
make DSTROOT="${pkgdir}" install
}