summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKevin Slagle2016-10-03 11:24:56 -0700
committerKevin Slagle2016-10-03 11:24:56 -0700
commit0046a79c585306ff8e31b88acac4dea746990a23 (patch)
tree2525ed26489ddf756c8064df8c9eb6c87113a0f4
parent677e6911a7047adcef1eee3961285efb90f08b68 (diff)
downloadaur-0046a79c585306ff8e31b88acac4dea746990a23.tar.gz
update to 11.0.1
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD64
2 files changed, 38 insertions, 34 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2a413b6be0f6..4fa136b9783f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,6 @@
-# Generated by mksrcinfo v8
-# Thu Aug 18 05:08:34 UTC 2016
pkgbase = mathematica
pkgdesc = A computational software program used in scientific, engineering, and mathematical fields and other areas of technical computing.
- pkgver = 11.0.0
+ pkgver = 11.0.1
pkgrel = 1
url = http://www.wolfram.com/mathematica/
install = mathematica.install
@@ -15,8 +13,8 @@ pkgbase = mathematica
depends = libxml2
optdepends = mesa-demos: glxinfo for "fully optimized graphics capabilities"
options = !strip
- source = local://Mathematica_11.0.0_LINUX.sh
- md5sums = 7addaeaeea255d8eaf1cd45be2924361
+ source = local://Mathematica_11.0.1_LINUX.sh
+ md5sums = 444f096c9e058d8a4f8555c06ccc0233
pkgname = mathematica
diff --git a/PKGBUILD b/PKGBUILD
index 0ce174336c5a..b139b194190b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@
# Contributor: Joshua Ellis <josh@jpellis.me>
pkgname=mathematica
-pkgver=11.0.0
+pkgver=11.0.1
pkgrel=1
pkgdesc="A computational software program used in scientific, engineering, and mathematical fields and other areas of technical computing."
arch=('i686' 'x86_64')
@@ -16,7 +16,7 @@ license=('proprietary')
depends=('ttf-bitstream-vera' 'libxcursor' 'alsa-lib' 'libxml2')
optdepends=('mesa-demos: glxinfo for "fully optimized graphics capabilities"') # without glxinfo, Mathematica outputs a warning to the terminal on startup
source=("local://Mathematica_${pkgver}_LINUX.sh")
-md5sums=('7addaeaeea255d8eaf1cd45be2924361')
+md5sums=('444f096c9e058d8a4f8555c06ccc0233')
install='mathematica.install'
options=('!strip')
@@ -26,30 +26,36 @@ PKGEXT=".pkg.tar"
# If you don't own the installer you can download a trial version at http://www.wolfram.com/mathematica/trial
build() {
- if [[ `echo "${srcdir}" | wc -w` -ne 1 ]]
- then echo
- echo "ERROR: The Mathematica installer doesn't support directory names with spaces. Try building from a directory without spaces."
- echo "current build directory: ${srcdir}"
- false
+ if [[ $(echo "${srcdir}" | wc -w) -ne 1 ]]; then
+ echo "ERROR: The Mathematica installer doesn't support directory names with spaces."
+ echo "Try building from a directory without spaces."
+ echo "Current build directory: ${srcdir}"
+ false
fi
-
+
chmod +x ${srcdir}/Mathematica_${pkgver}_LINUX.sh
}
package() {
+ echo "Running Mathematica installer"
# https://reference.wolfram.com/language/tutorial/InstallingMathematica.html#650929293
- ${srcdir}/Mathematica_${pkgver}_LINUX.sh -- -execdir=${pkgdir}/usr/bin -targetdir=${pkgdir}/opt/Mathematica -auto # -user
-
- echo "Fixing symbolic symlinks"
+ ${srcdir}/Mathematica_${pkgver}_LINUX.sh -- \
+ -execdir=${pkgdir}/usr/bin \
+ -targetdir=${pkgdir}/opt/Mathematica \
+ -auto # -user
+
+ echo "Fixing symbolic links"
cd ${pkgdir}/usr/bin
rm *
ln -s /opt/Mathematica/Executables/math
ln -s /opt/Mathematica/Executables/mathematica
ln -s /opt/Mathematica/Executables/Mathematica
- ln -s /opt/Mathematica/Executables/mcc
ln -s /opt/Mathematica/Executables/MathKernel
+ ln -s /opt/Mathematica/Executables/mcc
ln -s /opt/Mathematica/Executables/wolfram
ln -s /opt/Mathematica/Executables/WolframKernel
+
+ echo "Linking MathematicaScript"
if [ "${CARCH}" = "x86_64" ]; then
ln -s /opt/Mathematica/SystemFiles/Kernel/Binaries/Linux-x86-64/MathematicaScript
ln -s /opt/Mathematica/SystemFiles/Kernel/Binaries/Linux-x86-64/WolframScript
@@ -58,7 +64,7 @@ package() {
ln -s /opt/Mathematica/SystemFiles/Kernel/Binaries/Linux/WolframScript
fi
- echo "Copying menu and mimetype information..."
+ echo "Copying menu and mimetype information"
mkdir -p ${pkgdir}/usr/share/applications
mkdir -p ${pkgdir}/usr/share/desktop-directories
mkdir -p ${pkgdir}/usr/share/mime/packages
@@ -70,35 +76,35 @@ package() {
sed -Ei 's|^(\s*Exec=).*|\1/usr/bin/Mathematica %F|g' $desktopFile
cp $desktopFile ${pkgdir}/usr/share/applications/
echo -e 'Categories=Science;Math;NumericalAnalysis;DataVisualization;' >> ${pkgdir}/usr/share/applications/$desktopFile
-
+
cp wolfram-all.directory ${pkgdir}/usr/share/desktop-directories/
cp *.xml ${pkgdir}/usr/share/mime/packages/
- echo "Copying icons..."
+ echo "Copying icons"
mkdir -p ${pkgdir}/usr/share/icons/hicolor/{32x32,64x64,128x128}/{apps,mimetypes}
cd ${pkgdir}/opt/Mathematica/SystemFiles/FrontEnd/SystemResources/X
for i in "32" "64" "128"; do
- cp App.${i}.png ${pkgdir}/usr/share/icons/hicolor/${i}x${i}/apps/wolfram-mathematica.png
- cp vnd.wolfram.cdf.${i}.png ${pkgdir}/usr/share/icons/hicolor/${i}x${i}/mimetypes/application-vnd.wolfram.cdf.png
-
- cp vnd.wolfram.nb.${i}.png ${pkgdir}/usr/share/icons/hicolor/${i}x${i}/mimetypes/application-mathematica.png
- cp vnd.wolfram.player.${i}.png ${pkgdir}/usr/share/icons/hicolor/${i}x${i}/mimetypes/application-mathematicaplayer.png
- cp vnd.wolfram.cdf.${i}.png ${pkgdir}/usr/share/icons/hicolor/${i}x${i}/mimetypes/application-vnd.wolfram.cdf.png
-
- #cp vnd.wolfram.nb.${i}.png ${pkgdir}/usr/share/icons/hicolor/${i}x${i}/mimetypes/gnome-mime-application-mathematica.png
- #cp vnd.wolfram.player.${i}.png ${pkgdir}/usr/share/icons/hicolor/${i}x${i}/mimetypes/gnome-mime-application-mathematicaplayer.png
- #cp vnd.wolfram.cdf.${i}.png ${pkgdir}/usr/share/icons/hicolor/${i}x${i}/mimetypes/gnome-mime-application-vnd.wolfram.cdf.png
+ cp App-${i}.png \
+ ${pkgdir}/usr/share/icons/hicolor/${i}x${i}/apps/wolfram-mathematica.png
+ cp vnd.wolfram.cdf-${i}.png \
+ ${pkgdir}/usr/share/icons/hicolor/${i}x${i}/mimetypes/application-vnd.wolfram.cdf.png
+ cp vnd.wolfram.mathematica.package-${i}.png \
+ ${pkgdir}/usr/share/icons/hicolor/${i}x${i}/mimetypes/application-vnd.wolfram.mathematica.package.png
+ cp vnd.wolfram.nb-${i}.png \
+ ${pkgdir}/usr/share/icons/hicolor/${i}x${i}/mimetypes/application-vnd.wolfram.nb.png
+ cp vnd.wolfram.player-${i}.png \
+ ${pkgdir}/usr/share/icons/hicolor/${i}x${i}/mimetypes/application-vnd.wolfram.player.png
+ cp vnd.wolfram.wl-${i}.png \
+ ${pkgdir}/usr/share/icons/hicolor/${i}x${i}/mimetypes/application-vnd.wolfram.wl.png
done
- echo "Copying manpages..."
+ echo "Copying man pages"
mkdir -p ${pkgdir}/usr/share/man/man1
cd ${pkgdir}/opt/Mathematica/SystemFiles/SystemDocumentation/Unix
cp *.1 ${pkgdir}/usr/share/man/man1
- echo "Fixing file permissions..."
+ echo "Fixing file permissions"
chmod go-w -R ${pkgdir}/*
-
- echo "Done."
}
# vim:set ts=2 sw=2 et: