summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJP-Ellis2023-02-25 10:59:20 +1100
committerJP-Ellis2023-02-25 10:59:20 +1100
commit7ed5ebefadb4ae1d29ef44b9cd2582c69ebe6081 (patch)
tree4e7480a6cce52b2259af46edd4f3a5c916ce8529
parent9982eb00ab3b471d06f41f7461d2c50f71f5d652 (diff)
downloadaur-7ed5ebefadb4ae1d29ef44b9cd2582c69ebe6081.tar.gz
v13.2.1
With improvements suggested by qtmax. Signed-off-by: JP-Ellis <josh@jpellis.me>
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD36
-rw-r--r--remove-xdg-scripts.patch11
3 files changed, 43 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 187fdf7b4c97..bc2bc606ebd5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mathematica
pkgdesc = A computational software program used in scientific, engineering, and mathematical fields and other areas of technical computing with offline documentation.
- pkgver = 13.2.0
+ pkgver = 13.2.1
pkgrel = 1
url = http://www.wolfram.com/mathematica/
arch = x86_64
@@ -56,7 +56,9 @@ pkgbase = mathematica
optdepends = tesseract
optdepends = zlib
options = !strip
- source = local://Mathematica_13.2.0_BNDL_LINUX.sh
- md5sums = 05a0eaaafef2e4478454cb28e0ab4bc8
+ source = local://Mathematica_13.2.1_BNDL_LINUX.sh
+ source = remove-xdg-scripts.patch
+ md5sums = f796e96f6faeb441a8b24fb180d44e47
+ md5sums = 14df424ec93fad057604378c2b5c24c2
pkgname = mathematica
diff --git a/PKGBUILD b/PKGBUILD
index 39013d51d706..0ff7b9f74c6a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,9 +5,10 @@
# Contributor: Raphael Scholer <rscholer@gmx.de>
# Contributor: kjslag <kjslag at gmail dot com>
# Contributor: teratomata <teratomat@gmail.com>
+# Contributor: Maxim Mikityanskiy <maxtram95@gmail.com>
pkgname=mathematica
-pkgver=13.2.0
+pkgver=13.2.1
pkgrel=1
pkgdesc="A computational software program used in scientific, engineering, and mathematical fields and other areas of technical computing with offline documentation."
arch=('x86_64')
@@ -70,8 +71,14 @@ optdepends=(
'tesseract'
'zlib'
)
-source=("local://Mathematica_${pkgver}_BNDL_LINUX.sh")
-md5sums=('05a0eaaafef2e4478454cb28e0ab4bc8')
+source=(
+ "local://Mathematica_${pkgver}_BNDL_LINUX.sh"
+ "remove-xdg-scripts.patch"
+)
+md5sums=(
+ 'f796e96f6faeb441a8b24fb180d44e47'
+ '14df424ec93fad057604378c2b5c24c2'
+)
options=("!strip")
## To build this package you need to place the mathematica-installer into your
@@ -96,18 +103,29 @@ prepare() {
exit 1
fi
- chmod +x ${srcdir}/Mathematica_${pkgver}_BNDL_LINUX.sh
+ msg2 "Extracting Mathematica installer..."
+ sh "${srcdir}/Mathematica_${pkgver}_BNDL_LINUX.sh" \
+ --keep \
+ --target "${srcdir}/bundle" \
+ -- \
+ -help >/dev/null
+
+ patch -p1 -d "${srcdir}/bundle" < "${srcdir}/remove-xdg-scripts.patch"
}
package() {
msg2 "Running Mathematica installer"
# https://reference.wolfram.com/language/tutorial/InstallingMathematica.html#650929293
- sh ${srcdir}/Mathematica_${pkgver}_BNDL_LINUX.sh -- \
- -execdir=${pkgdir}/usr/bin \
- -targetdir=${pkgdir}/opt/Mathematica \
+ sh "${srcdir}/bundle/Unix/Installer/MathInstaller" \
+ -execdir="${pkgdir}/usr/bin" \
+ -targetdir="${pkgdir}/opt/Mathematica" \
-auto
- msg2 "Errors related to 'xdg-icon-resource' and 'xdg-desktop-menu' are to be expected during Mathematica's installation."
- rm ${pkgdir}/opt/Mathematica/InstallErrors
+
+ if [ -s "${pkgdir}/opt/Mathematica/InstallErrors" ]; then
+ msg2 "Review installation errors:"
+ cat "${pkgdir}/opt/Mathematica/InstallErrors"
+ fi
+ rm -f "${pkgdir}/opt/Mathematica/InstallErrors"
msg2 "Fixing symbolic links"
cd ${pkgdir}/opt/Mathematica/Executables
diff --git a/remove-xdg-scripts.patch b/remove-xdg-scripts.patch
new file mode 100644
index 000000000000..e44790d25705
--- /dev/null
+++ b/remove-xdg-scripts.patch
@@ -0,0 +1,11 @@
+--- a/Unix/Installer/MathInstaller
++++ b/Unix/Installer/MathInstaller
+@@ -1985,6 +1985,8 @@
+ xdgScripts="${FullTargetDirectory}/SystemFiles/Installation"
+ fi
+
++ rm "${xdgScripts}"/{xdg-icon-resource,xdg-desktop-menu,xdg-mime,xdg-desktop-icon}
++
+ if [ "${InstallerType}" != "App" ] &&
+ [ "${InstallerType}" != "DOC" ] &&
+ [ "${InstallerType}" != "gridMath" ]; then