summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJP-Ellis2021-07-11 12:09:12 +1000
committerJP-Ellis2021-07-11 12:40:09 +1000
commit90167bcae2acc282d7b17ae0b4f0a2a8d934303e (patch)
tree19773871c6dad938e8ed7eab9d639ce06fdd94c3
parent9f395c4fbacfc6034bb6ec6401442b779d4e0c0b (diff)
downloadaur-90167bcae2acc282d7b17ae0b4f0a2a8d934303e.tar.gz
v12.3.0
-rw-r--r--.SRCINFO7
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD12
3 files changed, 13 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index eb62308d935c..40ccce89d4d2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mathematica
pkgdesc = A computational software program used in scientific, engineering, and mathematical fields and other areas of technical computing.
- pkgver = 12.2.0
+ pkgver = 12.3.0
pkgrel = 1
url = http://www.wolfram.com/mathematica/
arch = x86_64
@@ -56,8 +56,7 @@ pkgbase = mathematica
optdepends = tesseract
optdepends = zlib
options = !strip
- source = local://Mathematica_12.2.0_LINUX.sh
- md5sums = 259a0b9688fa1829924497ef355816de
+ source = local://Mathematica_12.3.0_LINUX.sh
+ md5sums = e59534fde7df298cccbc0855b53f3514
pkgname = mathematica
-
diff --git a/.gitignore b/.gitignore
index 263bab96b916..0e5f346fc8db 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,3 +1,4 @@
Mathematica*.sh
*.pkg.tar
-*.pkg.tar.xz \ No newline at end of file
+*.pkg.tar.xz
+*.pkg.tar.zst \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
index 3146b166d4a8..16815df96376 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@
# Contributor: teratomata <teratomat@gmail.com>
pkgname=mathematica
-pkgver=12.2.0
+pkgver=12.3.0
pkgrel=1
pkgdesc="A computational software program used in scientific, engineering, and mathematical fields and other areas of technical computing."
arch=('x86_64')
@@ -71,7 +71,7 @@ optdepends=(
'zlib'
)
source=("local://Mathematica_${pkgver}_LINUX.sh")
-md5sums=('259a0b9688fa1829924497ef355816de')
+md5sums=('e59534fde7df298cccbc0855b53f3514')
options=("!strip")
## To build this package you need to place the mathematica-installer into your
@@ -128,7 +128,7 @@ package() {
mkdir -p ${srcdir}/WolframScript
mkdir -p ${pkgdir}/usr/share/
cd ${srcdir}/WolframScript
- bsdtar -xf ${pkgdir}/opt/Mathematica/SystemFiles/Installation/wolframscript_1.5.0+2020121053_amd64.deb data.tar.xz
+ bsdtar -xf ${pkgdir}/opt/Mathematica/SystemFiles/Installation/wolframscript_1.6.0+20210504145_amd64.deb data.tar.xz
tar -xf data.tar.xz -C ${pkgdir}/usr/share/ --strip=3 ./usr/share/
@@ -140,7 +140,7 @@ package() {
cd ${pkgdir}/opt/Mathematica/SystemFiles/Installation
desktopFile='wolfram-mathematica12.desktop'
sed -Ei 's|^(\s*TryExec=).*|\1/usr/bin/Mathematica|g' $desktopFile
- sed -Ei 's|^(\s*Exec=).*|\1/usr/bin/Mathematica %F|g' $desktopFile
+ sed -Ei 's|^(\s*Exec=).*|\1/usr/bin/Mathematica --name M-12.3 %F|g' $desktopFile
printf 'Categories=Science;Math;NumericalAnalysis;DataVisualization;\n' >> $desktopFile
printf 'StartupWMClass=Mathematica;\n' >> $desktopFile
cp $desktopFile ${pkgdir}/usr/share/applications/
@@ -162,6 +162,10 @@ package() {
cd ${pkgdir}/opt/Mathematica/SystemFiles/SystemDocumentation/Unix
cp *.1 ${pkgdir}/usr/share/man/man1
+ msg2 "Copying license"
+ mkdir -p ${pkgdir}/usr/share/license/Mathematica/
+ cp ${pkgdir}/opt/Mathematica/LICENSE.txt ${pkgdir}/usr/share/license/Mathematica/license.txt
+
msg2 "Fixing file permissions"
chmod go-w -R ${pkgdir}/*