summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJP-Ellis2021-12-15 12:10:32 +1100
committerJP-Ellis2021-12-15 12:10:32 +1100
commitfb434d49c282b416a60580447247d9b9574f1275 (patch)
tree273e9ea39771c3d2f28f27316be33a2a4b857a07
parenta6b409a51f2cf11e55d1983dd7779b708109f6f4 (diff)
downloadaur-fb434d49c282b416a60580447247d9b9574f1275.tar.gz
v13.0.0
Signed-off-by: JP-Ellis <josh@jpellis.me>
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD20
2 files changed, 14 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1ab8015b5704..f413b37eb340 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = mathematica
pkgdesc = A computational software program used in scientific, engineering, and mathematical fields and other areas of technical computing.
- pkgver = 12.3.1
- pkgrel = 2
+ pkgver = 13.0.0
+ pkgrel = 1
url = http://www.wolfram.com/mathematica/
arch = x86_64
license = proprietary
@@ -56,7 +56,7 @@ pkgbase = mathematica
optdepends = tesseract
optdepends = zlib
options = !strip
- source = local://Mathematica_12.3.1_LINUX.sh
- md5sums = 7a192570cdcac6b40fed09cc7015b6bd
+ source = local://Mathematica_13.0.0_BNDL_LINUX.sh
+ md5sums = e02f7c8926a51412a8d578de408e4b24
pkgname = mathematica
diff --git a/PKGBUILD b/PKGBUILD
index 9ca3f065a2e4..96f14817e6de 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,8 +7,8 @@
# Contributor: teratomata <teratomat@gmail.com>
pkgname=mathematica
-pkgver=12.3.1
-pkgrel=2
+pkgver=13.0.0
+pkgrel=1
pkgdesc="A computational software program used in scientific, engineering, and mathematical fields and other areas of technical computing."
arch=('x86_64')
url="http://www.wolfram.com/mathematica/"
@@ -70,8 +70,8 @@ optdepends=(
'tesseract'
'zlib'
)
-source=("local://Mathematica_${pkgver}_LINUX.sh")
-md5sums=('7a192570cdcac6b40fed09cc7015b6bd')
+source=("local://Mathematica_${pkgver}_BNDL_LINUX.sh")
+md5sums=('e02f7c8926a51412a8d578de408e4b24')
options=("!strip")
## To build this package you need to place the mathematica-installer into your
@@ -96,13 +96,13 @@ prepare() {
exit 1
fi
- chmod +x ${srcdir}/Mathematica_${pkgver}_LINUX.sh
+ chmod +x ${srcdir}/Mathematica_${pkgver}_BNDL_LINUX.sh
}
package() {
msg2 "Running Mathematica installer"
# https://reference.wolfram.com/language/tutorial/InstallingMathematica.html#650929293
- sh ${srcdir}/Mathematica_${pkgver}_LINUX.sh -- \
+ sh ${srcdir}/Mathematica_${pkgver}_BNDL_LINUX.sh -- \
-execdir=${pkgdir}/usr/bin \
-targetdir=${pkgdir}/opt/Mathematica \
-auto
@@ -128,7 +128,7 @@ package() {
mkdir -p ${srcdir}/WolframScript
mkdir -p ${pkgdir}/usr/share/
cd ${srcdir}/WolframScript
- bsdtar -xf ${pkgdir}/opt/Mathematica/SystemFiles/Installation/wolframscript_1.6.0+20210709241_amd64.deb data.tar.xz
+ bsdtar -xf ${pkgdir}/opt/Mathematica/SystemFiles/Installation/wolframscript_*_amd64.deb data.tar.xz
tar -xf data.tar.xz -C ${pkgdir}/usr/share/ --strip=3 ./usr/share/
@@ -138,10 +138,10 @@ package() {
${pkgdir}/usr/share/desktop-directories \
${pkgdir}/usr/share/mime/packages
cd ${pkgdir}/opt/Mathematica/SystemFiles/Installation
- desktopFile='wolfram-mathematica12.desktop'
+ desktopFile='wolfram-mathematica13.desktop'
sed -Ei 's|^(\s*TryExec=).*|\1/usr/bin/Mathematica|g' $desktopFile
- sed -Ei 's|^(\s*Exec=).*|\1/usr/bin/Mathematica --name M-12.3 %F|g' $desktopFile
- printf 'Categories=Science;Math;NumericalAnalysis;DataVisualization;\n' >> $desktopFile
+ sed -Ei 's|^(\s*Exec=).*|\1/usr/bin/Mathematica %F|g' $desktopFile
+ printf 'Categories=Science;Education;Languages;ArtificialIntelligence;Astronomy;Biology;Chemistry;ComputerScience;DataVisualization;Geography;ImageProcessing;Math;NumericalAnalysis;MedicalSoftware;Physics;ParallelComputer;\n' >> $desktopFile
printf 'StartupWMClass=Mathematica;\n' >> $desktopFile
cp $desktopFile ${pkgdir}/usr/share/applications/
cp wolfram-all.directory ${pkgdir}/usr/share/desktop-directories/