summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKevin Slagle2016-10-14 20:48:40 -0700
committerKevin Slagle2016-10-14 20:48:40 -0700
commitfef6d4536854395147be057e0b7743848ca7849f (patch)
tree9407d9d652a5600fc1c60e987d866057a239234a
parent0046a79c585306ff8e31b88acac4dea746990a23 (diff)
downloadaur-fef6d4536854395147be057e0b7743848ca7849f.tar.gz
check for and warn about building in tmpfs
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD9
2 files changed, 8 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4fa136b9783f..e9cb010047c3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,3 +1,5 @@
+# Generated by mksrcinfo v8
+# Sat Oct 15 03:48:37 UTC 2016
pkgbase = mathematica
pkgdesc = A computational software program used in scientific, engineering, and mathematical fields and other areas of technical computing.
pkgver = 11.0.1
diff --git a/PKGBUILD b/PKGBUILD
index b139b194190b..ae75916786ff 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -25,7 +25,12 @@ PKGEXT=".pkg.tar"
# To build this package you need to place the mathematica-installer into your startdir
# If you don't own the installer you can download a trial version at http://www.wolfram.com/mathematica/trial
-build() {
+package() {
+ if df "${pkgdir}" | grep -q tmpfs; then
+ warning "Building Mathematica takes more than 8GB of space."
+ warning "Building in a tmpfs (e.g. /tmp when mounted into RAM) may not work."
+ fi
+
if [[ $(echo "${srcdir}" | wc -w) -ne 1 ]]; then
echo "ERROR: The Mathematica installer doesn't support directory names with spaces."
echo "Try building from a directory without spaces."
@@ -34,9 +39,7 @@ build() {
fi
chmod +x ${srcdir}/Mathematica_${pkgver}_LINUX.sh
-}
-package() {
echo "Running Mathematica installer"
# https://reference.wolfram.com/language/tutorial/InstallingMathematica.html#650929293
${srcdir}/Mathematica_${pkgver}_LINUX.sh -- \