summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPopolon2021-03-17 15:11:06 +0100
committerPopolon2021-03-17 15:11:06 +0100
commit32f5967831fdc43cb6b48bd9ef57b675febcc421 (patch)
treeea31516d0dcf7395e8384a304f41d73e11ed2384
downloadaur-32f5967831fdc43cb6b48bd9ef57b675febcc421.tar.gz
Fist commit of this MathMod
-rw-r--r--.SRCINFO17
-rw-r--r--MathMod.desktop12
-rw-r--r--PKGBUILD35
3 files changed, 64 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9fe0d832defd
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = mathmod
+ pkgdesc = modelisation and manipulation of mathematics objects
+ pkgver = 11.0
+ pkgrel = 1
+ url = https://github.com/parisolab/mathmod/
+ arch = x86_64
+ arch = armv7h
+ arch = armv8
+ license = GPLv2
+ depends = qt5-base
+ source = https://github.com/parisolab/mathmod/archive/11.0.tar.gz
+ source = MathMod.desktop
+ sha256sums = 418e5a40dc0e9e7e41027d9d9f0fe7dc2a27a2df1711891451e7af4a04140dbe
+ sha256sums = 6c001dae8ae8c1f6a4aaef7bf2d098a058c1e944dbf01642ea9792926b7204e9
+
+pkgname = mathmod
+
diff --git a/MathMod.desktop b/MathMod.desktop
new file mode 100644
index 000000000000..951a10abf717
--- /dev/null
+++ b/MathMod.desktop
@@ -0,0 +1,12 @@
+[Desktop Entry]
+Name=MathMod
+Version=11.0
+Encoding=UTF-8
+Comment=Modelization and manipulation of 3D math objects
+Comment[fr]=Modélisation et manipulation d'objets mathématiques 3D
+Exec=MathMod
+Icon=MathMod
+Type=Applicationa
+Terminal=false
+Categories=Education;Science;Math;Graphics;
+Keywords:science;math;numerical computation;plotting
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..dc4281136d41
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Popolon <popolon@popolon.org>
+
+pkgname=mathmod
+pkgver=11.0
+pkgrel=1
+pkgdesc="modelisation and manipulation of mathematics objects"
+arch=('x86_64' 'armv7h' 'armv8')
+url="https://github.com/parisolab/mathmod/"
+license=('GPLv2')
+depends=('qt5-base')
+source=(https://github.com/parisolab/${pkgname}/archive/${pkgver}.tar.gz
+ MathMod.desktop)
+sha256sums=('418e5a40dc0e9e7e41027d9d9f0fe7dc2a27a2df1711891451e7af4a04140dbe'
+ '6c001dae8ae8c1f6a4aaef7bf2d098a058c1e944dbf01642ea9792926b7204e9')
+
+prepare() {
+ cd $pkgname-$pkgver
+ qmake
+}
+build() {
+ cd $pkgname-$pkgver
+ make
+}
+
+package() {
+
+ cd $pkgname-$pkgver
+ make install DESTDIR="$pkgdir" PREFIX=/usr
+ install -Dm 755 "MathMod" "${pkgdir}/usr/bin/MathMod"
+ install -Dm 644 "images/icone32x32.png" "${pkgdir}/usr/share/icons/MathMod.png"
+ install -Dm 644 "Licence.txt" "${pkgdir}/usr/share/licenses/${pkgname}/Licence.txt"
+ cd -
+ install -Dm 644 "MathMod.desktop" "${pkgdir}/usr/share/applications/MathMod.desktop"
+
+}