summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBuildTools2018-10-13 10:46:09 +0900
committerBuildTools2018-10-13 10:46:09 +0900
commitf91ec0cc8ec266be3f108fd1c970952a5b61424f (patch)
tree993b7f241e5f453bd5e6e0fdef9af56d1210b599
downloadaur-f91ec0cc8ec266be3f108fd1c970952a5b61424f.tar.gz
initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD31
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a626a455e713
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = mathpix-snipping-tool
+ pkgdesc = Mathpix Snipping Tool
+ pkgver = 00.00.0057
+ pkgrel = 1
+ url = https://snapcraft.io/mathpix-snipping-tool
+ arch = x86_64
+ license = unknown
+ makedepends = squashfs-tools
+ depends = qt5-x11extras
+ depends = qt5-webkit
+ source = https://api.snapcraft.io/api/v1/snaps/download/jnlZEYdmdXGhh6oJTtMsawNGZzEWmMhk_19.snap
+ md5sums = bbafafe6622ee76da6de0eb336c955bd
+
+pkgname = mathpix-snipping-tool
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3367b9fc8fa9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: HRKo <ootaharuki99 at gmail.com>
+pkgname=mathpix-snipping-tool
+pkgver=00.00.0057
+pkgrel=1
+pkgdesc="Mathpix Snipping Tool"
+arch=('x86_64')
+url="https://snapcraft.io/mathpix-snipping-tool"
+license=('unknown')
+makedepends=('squashfs-tools')
+depends=('qt5-x11extras' 'qt5-webkit')
+source=('https://api.snapcraft.io/api/v1/snaps/download/jnlZEYdmdXGhh6oJTtMsawNGZzEWmMhk_19.snap')
+md5sums=('bbafafe6622ee76da6de0eb336c955bd')
+
+## run these to get the source URL and the version
+# curl -H 'X-Ubuntu-Series: 16' https://api.snapcraft.io/api/v1/snaps/details/mathpix-snipping-tool | jq '.download_url' -r
+# curl -H 'X-Ubuntu-Series: 16' https://api.snapcraft.io/api/v1/snaps/details/mathpix-snipping-tool | jq '.version' -r
+
+prepare() {
+ cd $srcdir
+ unsquashfs -f jnlZEYdmdXGhh6oJTtMsawNGZzEWmMhk_19.snap /usr/bin/mathpix-snipping-tool \
+ /meta/gui/mathpix-snipping-tool.desktop \
+ /meta/gui/icon.svg
+ sed 's|${SNAP}/meta/gui/icon.svg|mathpix-snipping-tool|g' -i squashfs-root/meta/gui/mathpix-snipping-tool.desktop
+}
+
+package() {
+ cd $srcdir/squashfs-root
+ install -Dm0644 meta/gui/mathpix-snipping-tool.desktop $pkgdir/usr/share/applications/mathpix-snipping-tool.desktop
+ install -Dm0644 meta/gui/icon.svg $pkgdir/usr/share/icons/mathpix-snipping-tool.svg
+ install -Dm0755 usr/bin/mathpix-snipping-tool $pkgdir/usr/bin/mathpix-snipping-tool
+}