summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarat Kh. Akhin2015-07-01 12:56:55 +0300
committerMarat Kh. Akhin2015-07-01 12:56:55 +0300
commit84c7e3124cbaa6b4038dbecc383c4a2a525960d7 (patch)
tree7d5dd0f8953d36c0bd3a385221d2b890db3a5108
downloadaur-84c7e3124cbaa6b4038dbecc383c4a2a525960d7.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD32
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6c843303c3f5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = mathsat-5
+ pkgdesc = MathSAT 5 is an efficient SMT solver supporting a wide range of theories and functionalities
+ pkgver = 5.2.10
+ pkgrel = 3
+ url = http://mathsat.fbk.eu/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ license = LGPL
+ license = custom
+ options = staticlibs
+ source = mathsat-5-5.2.10.tar.gz::http://mathsat.fbk.eu/download.php?file=mathsat-5.2.10-linux-.tar.gz
+ md5sums = 124503e736ebb0240606fd370d6c5651
+
+pkgname = mathsat-5
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3d0214ac0f5c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Marat Akhin <Marat.Akhin@gmail.com>
+# Contributor: Kirill Gagarsky <???>
+
+pkgname=mathsat-5
+pkgver=5.2.10
+pkgrel=3
+pkgdesc="MathSAT 5 is an efficient SMT solver supporting a wide range of theories and functionalities"
+arch=('i686' 'x86_64')
+url="http://mathsat.fbk.eu/"
+license=('GPL' 'LGPL' 'custom')
+
+download_arch=$CARCH
+[[ $CARCH == "i686" ]] && download_arch="x86"
+
+source=("$pkgname-$pkgver.tar.gz::http://mathsat.fbk.eu/download.php?file=mathsat-$pkgver-linux-$download_arch.tar.gz")
+
+md5sums=('124503e736ebb0240606fd370d6c5651')
+[[ $CARCH == "i686" ]] && md5sums=('69200ea86f663d93c2d1df6c4b17655d')
+
+options=('staticlibs')
+
+package() {
+ mkdir -p "$pkgdir/usr/bin"
+ mkdir -p "$pkgdir/usr/include/mathsat"
+ mkdir -p "$pkgdir/usr/lib"
+
+ cp -r "$srcdir/mathsat-$pkgver-linux-$download_arch/bin/." "$pkgdir/usr/bin/"
+ cp -r "$srcdir/mathsat-$pkgver-linux-$download_arch/include/." "$pkgdir/usr/include/mathsat/"
+ cp -r "$srcdir/mathsat-$pkgver-linux-$download_arch/lib/." "$pkgdir/usr/lib/"
+
+ install -Dm644 "$srcdir/mathsat-$pkgver-linux-$download_arch/LICENSE.txt" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}