aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGrey Christoforo2017-08-22 11:47:23 +0100
committerGrey Christoforo2017-08-22 11:47:23 +0100
commite44e6c76342466f2fc9ba8fbf2a098deaed75993 (patch)
treed8086f3a14418bb251313deffb44f6537d025768
parent95382c3898b9272ee9005ddf36b9c15726540d25 (diff)
downloadaur-e44e6c76342466f2fc9ba8fbf2a098deaed75993.tar.gz
version bump and some clean up for R2017a
-rw-r--r--.SRCINFO7
-rw-r--r--.gitignore8
-rw-r--r--PKGBUILD19
3 files changed, 24 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 78cf5700ff2e..6cb093ce4065 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,8 @@
+# Generated by mksrcinfo v8
+# Tue Aug 22 10:44:51 UTC 2017
pkgbase = matlab
pkgdesc = A high-level language for numerical computation and visualization
- pkgver = 08.06.00
+ pkgver = 9.2.0.556344
pkgrel = 1
url = http://www.mathworks.com
arch = x86_64
@@ -16,6 +18,7 @@ pkgbase = matlab
depends = libxtst
depends = ncurses5-compat-libs
depends = nss
+ depends = gcc5
depends = portaudio
depends = python2
depends = qt5-svg
@@ -25,7 +28,7 @@ pkgbase = matlab
depends = xerces-c
optdepends = gcc47: For MEX support
optdepends = gcc47-fortran: For MEX support
- source = file://matlab.iso
+ source = file://matlab.zip
source = file://matlab.fik
md5sums = SKIP
md5sums = SKIP
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..403762f058b4
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,8 @@
+*.tar.gz
+*.tar.xz
+*.tar
+*.zip
+*.fik
+*.lic
+src/
+pkg/
diff --git a/PKGBUILD b/PKGBUILD
index dfa87c66ebc5..eb0cba981b1e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,12 +1,11 @@
-# Maintainer: Daniel E. Shub <daniel.e.shub@gmail.com>
-# Maintainer: Ido Rosen <ido@kernel.org>
+# Maintainer: Grey Christoforo <first name at last name dot net>
-## This PKGBUILD creates an Arch Linux package for the proprietary MATLAB application. A license from The MathWorks is needed in order to both build the package and to run MATLAB once the package is installed. In order to build the package the user must supply a plain text file installation key and the software. For network installations, in addition to the file installation key, a license file needs to be used for the installation. The ISO file can be downloaded from The MathWorks, generated from the official DVD, or created by using the interactive installer to download the toolboxes (installation can be made to a temporary directory and canceled once the toolboxes are downloaded). The contents of the ISO file must include: ./archives/ ./bin/ ./etc/ ./help/ ./java/ /sys ./activate.ini ./install ./installer_input.txt
+## This PKGBUILD creates an Arch Linux package for the proprietary MATLAB application. A license from The MathWorks is needed in order to both build the package and to run MATLAB once the package is installed. In order to build the package the user must supply a plain text file installation key and the software. For network installations, in addition to the file installation key, a license file needs to be used for the installation. The tar archive file can be generated from an ISO downloaded from The MathWorks, generated from the official DVD, or created by using the interactive installer to download the toolboxes (installation can be made to a temporary directory and canceled once the toolboxes are downloaded). The contents of the tar archive must include: ./archives/ ./bin/ ./etc/ ./help/ ./java/ /sys ./activate.ini ./install ./installer_input.txt
-## The default installation behavior is to install all licensed products whether or not they are available in the iso file. To install only a subset of licensed products either provide a $_products array or set $_partialinstall and remove unwanted entries from the provided $_products array. To perform a network install set $_networkinstall.
+## The default installation behavior is to install all licensed products whether or not they are available in the tar file. To install only a subset of licensed products either provide a $_products array or set $_partialinstall and remove unwanted entries from the provided $_products array. To perform a network install set $_networkinstall.
pkgname=matlab
-pkgver=08.06.00
+pkgver=9.2.0.556344
pkgrel=1
pkgdesc='A high-level language for numerical computation and visualization'
arch=('x86_64')
@@ -23,6 +22,7 @@ depends=('gconf'
'libxtst'
'ncurses5-compat-libs'
'nss'
+ 'gcc5'
'portaudio'
'python2'
'qt5-svg'
@@ -32,8 +32,8 @@ depends=('gconf'
'xerces-c')
optdepends=('gcc47: For MEX support'
'gcc47-fortran: For MEX support')
-source=("file://${pkgname}.iso"
- "file://${pkgname}.fik")
+source=("file://matlab.tar"
+ "file://matlab.fik")
md5sums=('SKIP'
'SKIP')
@@ -88,7 +88,10 @@ package() {
## See $MATLABROOT/sys/os/glnxa64/README.libstdc++
msg2 'Removing unused library files'
- rm ${pkgdir}/opt/tmw/${pkgname}/sys/os/glnxa64/{libstdc++.so.6.0.17,libstdc++.so.6,libgcc_s.so.1,libgfortran.so.3.0.0,libgfortran.so.3,libquadmath.so.0.0.0,libquadmath.so.0}
+ rm ${pkgdir}/opt/tmw/${pkgname}/sys/os/glnxa64/{libstdc++.so.6.0.20,libstdc++.so.6,libgcc_s.so.1,libgfortran.so.3.0.0,libgfortran.so.3,libquadmath.so.0.0.0,libquadmath.so.0}
+
+ # make sure MATLAB can find libgfortran.so.3
+ sed -i 's,LD_LIBRARY_PATH="`eval echo $LD_LIBRARY_PATH`",LD_LIBRARY_PATH="`eval echo $LD_LIBRARY_PATH`:/usr/lib/gcc/x86_64-pc-linux-gnu/5.4.0",g' "${pkgdir}/opt/tmw/matlab/bin/matlab"
}
## For network installations, apparently, a license file needs to be used for the installation.