summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorZhang Hai2017-09-26 19:46:53 -0700
committerZhang Hai2017-09-26 19:47:05 -0700
commitc5fe0e38cd95f836f86246b7b02d68e57dca3528 (patch)
tree1ccf5bb5cd0c17601ea3b669589903db44ab0fbc
parent9c0d5740fd63122bcff7f580d20149425944105c (diff)
downloadaur-c5fe0e38cd95f836f86246b7b02d68e57dca3528.tar.gz
Add fix for conflict with texlive.
-rw-r--r--PKGBUILD7
1 files changed, 5 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 33c969d4e272..0e84ef627dc6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -44,9 +44,12 @@ package() {
msg2 'Creating links for executables'
install -d -m755 "${pkgdir}/usr/bin/"
- for _executable in deploytool matlab mbuild mcc mex; do
- ln -s "/opt/${_pkgname}/bin/${_executable}" "${pkgdir}/usr/bin/${_executable}"
+ for executable in deploytool matlab mbuild mcc mex; do
+ ln -s "/opt/${_pkgname}/bin/${executable}" "${pkgdir}/usr/bin/${executable}"
done
+ msg2 'If you see a conflict with texlive on /usr/bin/mex upon install, edit PKGBUILD and uncomment the following lines'
+ # rm "${pkgdir}/usr/bin/mex"
+ # ln -s "/opt/${_pkgname}/bin/mex" "${pkgdir}/usr/bin/matlab-mex"
msg2 'Installing desktop files'
install -D -m644 "${_pkgname}.desktop" "${pkgdir}/usr/share/applications/${_pkgname}.desktop"