summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael R. Shannon2017-03-31 16:53:16 -0600
committerMichael R. Shannon2017-03-31 16:53:16 -0600
commit77bcafd15cb39a87d265f9cd5b496bfdd539682e (patch)
treeaa5dead5df3fa905602e2604139c170255f7802c
parent3c90156b956f11f9b020741203de3c7c9bdd7953 (diff)
downloadaur-77bcafd15cb39a87d265f9cd5b496bfdd539682e.tar.gz
Patch from gcc-4.7 to gcc-4.9.
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD2
-rw-r--r--matlab-support.install19
3 files changed, 13 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2a07330e4c42..0d14970ef1bc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = matlab-support
pkgdesc = Provides dependencies and common fixes for MATLAB.
pkgver = 9.2.0
- pkgrel = 2
+ pkgrel = 3
url = http://www.mathworks.com
install = matlab-support.install
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index eb567c75b536..7e57260e2d9f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -21,7 +21,7 @@
pkgname=matlab-support
pkgver=9.2.0
-pkgrel=2
+pkgrel=3
pkgdesc='Provides dependencies and common fixes for MATLAB.'
arch=('x86_64')
url='http://www.mathworks.com'
diff --git a/matlab-support.install b/matlab-support.install
index b48c0d294cfc..975835e23a18 100644
--- a/matlab-support.install
+++ b/matlab-support.install
@@ -7,16 +7,19 @@ post_install() {
}
post_upgrade() {
bin_path=$(dirname $(readlink -f $(which matlab)))
- echo 'Patching MATLAB to use gcc-4.7'
- sed -i "s/CC='gcc'$/CC='gcc-4.7'/g" "$bin_path/mexopts.sh"
- sed -i "s/CXX='g++'$/CXX='g++-4.7'/g" "$bin_path/mexopts.sh"
- sed -i "s/FC='gfortran'$/FC='gfortran-4.7'/g" "$bin_path/mexopts.sh"
+ echo 'Patching MATLAB to use gcc-4.9'
+ sed -i "s/CC='gcc-4.7'$/CC='gcc-4.9'/g" "$bin_path/mexopts.sh"
+ sed -i "s/CXX='g++-4.7'$/CXX='g++-4.9'/g" "$bin_path/mexopts.sh"
+ sed -i "s/FC='gfortran-4.7'$/FC='gfortran-4.9'/g" "$bin_path/mexopts.sh"
+ sed -i "s/CC='gcc'$/CC='gcc-4.9'/g" "$bin_path/mexopts.sh"
+ sed -i "s/CXX='g++'$/CXX='g++-4.9'/g" "$bin_path/mexopts.sh"
+ sed -i "s/FC='gfortran'$/FC='gfortran-4.9'/g" "$bin_path/mexopts.sh"
}
post_remove() {
bin_path=$(dirname $(readlink -f $(which matlab)))
- echo 'Removing gcc-4.7 patch'
- sed -i "s/CC='gcc-4.7'$/CC='gcc'/g" "$bin_path/mexopts.sh"
- sed -i "s/CXX='g++-4.7'$/CXX='g++'/g" "$bin_path/mexopts.sh"
- sed -i "s/FC='gfortran-4.7'$/FC='gfortran'/g" "$bin_path/mexopts.sh"
+ echo 'Removing gcc-4.9 patch'
+ sed -i "s/CC='gcc-4.9'$/CC='gcc'/g" "$bin_path/mexopts.sh"
+ sed -i "s/CXX='g++-4.9'$/CXX='g++'/g" "$bin_path/mexopts.sh"
+ sed -i "s/FC='gfortran-4.9'$/FC='gfortran'/g" "$bin_path/mexopts.sh"
}