summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAriel Lieberman2018-10-05 16:54:48 +0300
committerAriel Lieberman2018-10-05 16:54:48 +0300
commitdfe58516429519a253752ef645cf84afcf4221fc (patch)
treee536dc4e07796c005f0b0a822a20f6bf51949a5a
parentd333709cd8006035d82967bea42c65525fafc493 (diff)
downloadaur-dfe58516429519a253752ef645cf84afcf4221fc.tar.gz
Upgrade to 9.5.0 (R2018b)
-rw-r--r--.SRCINFO29
-rw-r--r--PKGBUILD57
-rw-r--r--matlab-support.install25
3 files changed, 45 insertions, 66 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f59cbc1b286..c770d2495b5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,27 @@
pkgbase = matlab-support
- pkgdesc = Provides dependencies and common fixes for MATLAB.
- pkgver = 9.2.0
- pkgrel = 4
+ pkgdesc = Provides dependencies desktop file and common fixes for MATLAB.
+ pkgver = 9.5.0
+ pkgrel = 1
url = http://www.mathworks.com
- install = matlab-support.install
arch = x86_64
license = custom
makedepends = gendesk
- depends = libx11
- depends = libxext
- depends = libxt
- depends = jre7-openjdk
- depends = libselinux
- optdepends = gcc49: For MEX support
+ depends = gconf
+ depends = glu
+ depends = gtk2
+ depends = libunwind
+ depends = libxp
+ depends = libxpm
+ depends = libxtst
+ depends = nss
+ depends = portaudio
+ depends = python2
+ depends = qt5-svg
+ depends = qt5-webkit
+ depends = qt5-websockets
+ depends = qt5-x11extras
+ depends = xerces-c
+ optdepends = gcc6: For MEX support
provides = matlab
conflicts = matlab
source = https://upload.wikimedia.org/wikipedia/commons/2/21/Matlab_Logo.png
diff --git a/PKGBUILD b/PKGBUILD
index 151fb690a85..35f5a1a02c8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,16 @@
-# Maintainer: Michael R. Shannon <mrshannon.aerospace@gmail.com>
+# Maintainer: Ariel Lieberman <rellieberman at gmail dot com>
+# Contributer: Michael R. Shannon <mrshannon.aerospace@gmail.com>
## This PKGBUILD installs dependencies, provides desktop icons, and patches a
## currently installed version MATLAB. It should be installed after a manual
-## install of MATLAB and will find the location where MATLAB is installed as
+## install of MATLAB and will find the location where MATLAB is installed
## assuming the executable is on the PATH. This package should not be used with
## the AUR matlab package by Daniel Shub and Ido Rosen.
## The version of this package will always match the MATLAB ## version numbers
## (of which you can find here
## https://en.wikipedia.org/wiki/MATLAB#Release_history) for which this package
-## is intended to support. Please flag as our of date upon a new MATLAB
+## is intended to support. Please flag as out of date upon a new MATLAB
## release.
## MATLAB is a commercial product with a paid license, this package does not
@@ -20,22 +21,33 @@
## guide when making this one.
pkgname=matlab-support
-pkgver=9.2.0
-pkgrel=4
-pkgdesc='Provides dependencies and common fixes for MATLAB.'
+pkgver=9.5.0
+pkgrel=1
+pkgdesc='Provides dependencies desktop file and common fixes for MATLAB.'
arch=('x86_64')
url='http://www.mathworks.com'
license=(custom)
-depends=('libx11'
- 'libxext'
- 'libxt'
- 'jre7-openjdk'
- 'libselinux')
-optdepends=('gcc49: For MEX support')
+depends=('gconf'
+ 'glu'
+ #'gstreamer0.10-base'
+ 'gtk2'
+ 'libunwind'
+ 'libxp'
+ 'libxpm'
+ 'libxtst'
+ #'ncurses5-compat-libs'
+ 'nss'
+ 'portaudio'
+ 'python2'
+ 'qt5-svg'
+ 'qt5-webkit'
+ 'qt5-websockets'
+ 'qt5-x11extras'
+ 'xerces-c')
+optdepends=('gcc6: For MEX support')
makedepends=('gendesk')
provides=('matlab')
conflicts=('matlab')
-install=${pkgname}.install
source=('https://upload.wikimedia.org/wikipedia/commons/2/21/Matlab_Logo.png')
sha512sums=('ba72458379c89b22a27d1d7e357cefae4437fa28caac47b26ccd4f5b01b8cbc2c000baf38b5a52565f29b14e6da922bc3dc14bc5d47fa682fb6871422a59c397')
@@ -44,30 +56,13 @@ prepare() {
gendesk -f -n --pkgname 'matlab' \
--pkgdesc 'A high-level language for numerical computation and visualization.' \
--categories 'Development;Education;science;Mathematics;IDE' \
- --exec 'matlab -desktop -nosplash' \
+ --exec --exec 'env LD_PRELOAD=/usr/lib/libfreetype.so.6:/usr/lib/libstdc++.so.6 matlab -desktop' \
--mimetypes 'text/x-matlab' \
"${srcdir}/matlab.desktop" >/dev/null
-
- msg2 'Creating command line executable'
- echo -e "#!/bin/sh\nmatlab -nodesktop -nosplash" > "${srcdir}/matlab-cli"
-
- # If you never let MATLAB connect to the internet or run MATLAB on a server
- # the Java version it includes should be fine but otherwise the outdated
- # Java that ships with MATLAB is a security risk.
- msg2 'Creating profile.d files'
- echo -e "export MATLAB_JAVA=/usr/lib/jvm/java-7-openjdk/jre" > "${srcdir}/matlab.sh"
- echo -e "setenv MATLAB_JAVA /usr/lib/jvm/java-7-openjdk/jre" > "${srcdir}/matlab.csh"
}
package() {
msg2 'Installing desktop files'
install -D -m644 "matlab.desktop" "${pkgdir}/usr/share/applications/matlab.desktop"
install -D -m644 "Matlab_Logo.png" "${pkgdir}/usr/share/pixmaps/matlab.png"
-
- msg2 'Installing command line executable'
- install -D -m755 'matlab-cli' "${pkgdir}/usr/bin/matlab-cli"
-
- msg2 'Installing profile.d files'
- install -D -m644 'matlab.sh' "${pkgdir}/etc/profile.d/matlab.sh"
- install -D -m644 'matlab.csh' "${pkgdir}/etc/profile.d/matlab.csh"
}
diff --git a/matlab-support.install b/matlab-support.install
deleted file mode 100644
index c8d7d4deead..00000000000
--- a/matlab-support.install
+++ /dev/null
@@ -1,25 +0,0 @@
-## This install script will find the currently installed version of MATLAB (via
-## the PATH) and patch the mexopts.sh script to use GCC 4.9 from the AUR. This
-## is required as MATLAB does not currently support versions newer than 4.9.
-
-post_install() {
- post_upgrade
-}
-post_upgrade() {
- bin_path=$(dirname $(readlink -f $(which matlab)))
- echo 'Patching MATLAB to use gcc-4.9'
- sed -i "s/CC='gcc-4.7'$/CC='gcc-4.9'/g" "$bin_path/mexopts.sh"
- sed -i "s/CXX='g++-4.7'$/CXX='g++-4.9'/g" "$bin_path/mexopts.sh"
- sed -i "s/FC='gfortran-4.7'$/FC='gfortran-4.9'/g" "$bin_path/mexopts.sh"
- sed -i "s/CC='gcc'$/CC='gcc-4.9'/g" "$bin_path/mexopts.sh"
- sed -i "s/CXX='g++'$/CXX='g++-4.9'/g" "$bin_path/mexopts.sh"
- sed -i "s/FC='gfortran'$/FC='gfortran-4.9'/g" "$bin_path/mexopts.sh"
-}
-
-post_remove() {
- bin_path=$(dirname $(readlink -f $(which matlab)))
- echo 'Removing gcc-4.9 patch'
- sed -i "s/CC='gcc-4.9'$/CC='gcc'/g" "$bin_path/mexopts.sh"
- sed -i "s/CXX='g++-4.9'$/CXX='g++'/g" "$bin_path/mexopts.sh"
- sed -i "s/FC='gfortran-4.9'$/FC='gfortran'/g" "$bin_path/mexopts.sh"
-}