summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilip Goto2016-09-05 20:20:01 +0200
committerPhilip Goto2016-09-05 20:20:01 +0200
commitc385add53779fd5a2070222ee11dc791ef281dce (patch)
treee8e28300df84324bedd2aa4cb5350c155e86b1f9
downloadaur-c385add53779fd5a2070222ee11dc791ef281dce.tar.gz
Initialize mato-icons-git package
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD29
-rw-r--r--mato-icons-git.install12
3 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d1815ca99402
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = mato-icons-git
+ pkgdesc = Mato is a Material Design inspired icon theme for Linux. It features simple and modern icons based on the official icons.
+ pkgver = 6e62401
+ pkgrel = 1
+ url = https://github.com/flipflop97/Mato
+ install = mato-icons-git.install
+ arch = any
+ license = Creative Commons Attribution-ShareAlike 4.0 International Public License
+ makedepends = git
+ provides = mato-icons-git
+ options = !strip
+ options = !emptydirs
+ source = mato-icons-git::git+https://github.com/flipflop97/Mato.git
+ sha256sums = SKIP
+
+pkgname = mato-icons-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b06400cb04f6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Philip Goto
+pkgname=mato-icons-git
+pkgver=6e62401
+pkgrel=1
+pkgdesc="Mato is a Material Design inspired icon theme for Linux. It features simple and modern icons based on the official icons."
+arch=('any')
+url="https://github.com/flipflop97/Mato"
+license=('Creative Commons Attribution-ShareAlike 4.0 International Public License')
+makedepends=('git')
+provides=('mato-icons-git')
+options=(!strip !emptydirs)
+install='mato-icons-git.install'
+source=("${pkgname}::git+https://github.com/flipflop97/Mato.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${pkgname}"
+ git rev-parse --short HEAD
+}
+
+package() {
+ install -dm 755 "${pkgdir}"/usr/share/icons
+
+ mkdir "${pkgdir}"/usr/share/icons/Mato
+
+ cp -dr --no-preserve='ownership' "${pkgname}"/* "${pkgdir}"/usr/share/icons/Mato
+ rm "${pkgdir}"/usr/share/icons/Mato/install.sh
+
+}
diff --git a/mato-icons-git.install b/mato-icons-git.install
new file mode 100644
index 000000000000..241045e50390
--- /dev/null
+++ b/mato-icons-git.install
@@ -0,0 +1,12 @@
+post-install() {
+ # icon cache
+ gtk-update-icon-cache Mato
+}
+
+post-upgrade() {
+ post-install
+}
+
+post-remove() {
+ post-install
+}