summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoracxz2020-03-16 02:52:05 -0400
committeracxz2020-03-16 02:52:05 -0400
commitb9f05d4a8fee846d8535fd7a27d1a47ccdbdcc3c (patch)
tree599acf648a0175d059b130e34f4552ddd61a7323
downloadaur-b9f05d4a8fee846d8535fd7a27d1a47ccdbdcc3c.tar.gz
create matplotlib-cpp package
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD27
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..97258b73e005
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = matplotlib-cpp-git
+ pkgdesc = Extremely simple yet powerful header-only C++ plotting library built on the popular matplotlib
+ pkgver = r121.f23347f
+ pkgrel = 1
+ url = https://github.com/lava/matplotlib-cpp
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = gcc
+ makedepends = cmake
+ depends = gcc
+ depends = python-matplotlib
+ depends = python-numpy
+ depends = python
+ provides = matplotlib-cpp
+ source = git+https://github.com/lava/matplotlib-cpp
+ sha256sums = SKIP
+
+pkgname = matplotlib-cpp-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4dc8732bb2a0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: acxz <akashpatel2008 at yahoo dot com>
+
+pkgname=matplotlib-cpp-git
+pkgver=r121.f23347f
+pkgrel=1
+pkgdesc="Extremely simple yet powerful header-only C++ plotting library built on
+ the popular matplotlib"
+arch=('i686' 'x86_64')
+url='https://github.com/lava/matplotlib-cpp'
+license=('MIT')
+depends=('gcc' 'python-matplotlib' 'python-numpy' 'python')
+optdepends=()
+makedepends=('gcc' 'cmake')
+provides=('matplotlib-cpp')
+_pkgname=matplotlib-cpp
+source=(git+https://github.com/lava/${_pkgname})
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$_pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ mkdir -p "${pkgdir}/usr/include/${_pkgname}"
+ cp "${srcdir}/${_pkgname}/matplotlibcpp.h" "${pkgdir}/usr/include/${_pkgname}"
+}