summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoracxz2023-03-29 15:38:25 -0500
committeracxz2023-03-29 15:40:13 -0500
commit8bd3cd00362c5266ada0798ae493b477e9924339 (patch)
treea41d2b150cda8c70ff59d88541f3a04f584a686e
downloadaur-8bd3cd00362c5266ada0798ae493b477e9924339.tar.gz
create matplotplusplus-git package
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD33
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1ee7a306cc5e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = matplotplusplus-git
+ pkgdesc = Matplot++: A C++ Graphics Library for Data Visualization
+ pkgver = r437.2a8eada
+ pkgrel = 1
+ url = https://alandefreitas.github.io/matplotplusplus/
+ arch = x86_64
+ license = MIT
+ makedepends = cmake
+ depends = gnuplot
+ source = matplotplusplus-git::git+https://github.com/alandefreitas/matplotplusplus
+ sha256sums = SKIP
+
+pkgname = matplotplusplus-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ab0697c95a50
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: acxz <akashpatel2008 at yahoo dot com>
+pkgname=matplotplusplus-git
+pkgver=r437.2a8eada
+pkgrel=1
+pkgdesc="Matplot++: A C++ Graphics Library for Data Visualization"
+url="https://alandefreitas.github.io/matplotplusplus/"
+arch=(x86_64)
+license=('MIT')
+makedepends=(cmake)
+depends=(gnuplot)
+source=("${pkgname}::git+https://github.com/alandefreitas/matplotplusplus")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/${pkgname}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ mkdir -p "$srcdir/${pkgname}/build"
+ cd "$srcdir/${pkgname}/build"
+ cmake -DCMAKE_INSTALL_PREFIX="$pkgdir/usr" \
+ -DMATPLOTPP_BUILD_SHARED_LIBS=ON \
+ -DMATPLOTPP_BUILD_EXAMPLES=OFF \
+ -DMATPLOTPP_BUILD_TESTS=OFF \
+ ..
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname}/build"
+ make DESDIR=${pkgdir} install
+}