summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorIvan Shapovalov2015-08-21 17:23:48 +0300
committerIvan Shapovalov2015-08-21 17:23:48 +0300
commitee9a678d49ca3e30a0af03a23ac757c3b7331009 (patch)
tree2af382beba22e7060e82cd77c3d846ccca7b98a7
parent2f9964b4394c664eef0c9f6b85b2b59a11b62180 (diff)
downloadaur-ee9a678d49ca3e30a0af03a23ac757c3b7331009.tar.gz
Actually remove the Twisted compat patch.
-rw-r--r--twisted-15.1.0-compat.patch48
1 files changed, 0 insertions, 48 deletions
diff --git a/twisted-15.1.0-compat.patch b/twisted-15.1.0-compat.patch
deleted file mode 100644
index b2d95e8500e9..000000000000
--- a/twisted-15.1.0-compat.patch
+++ /dev/null
@@ -1,48 +0,0 @@
-diff --git a/setup.py b/setup.py
-index ab24159..af03c0a 100755
---- a/setup.py
-+++ b/setup.py
-@@ -47,7 +47,7 @@ setup(
- description="Reference Synapse Home Server",
- install_requires=dependencies['requirements'](include_conditional=True).keys(),
- setup_requires=[
-- "Twisted==14.0.2", # Here to override setuptools_trial's dependency on Twisted>=2.4.0
-+ "Twisted==15.1.0", # Here to override setuptools_trial's dependency on Twisted>=2.4.0
- "setuptools_trial",
- "mock"
- ],
-diff --git a/synapse/http/matrixfederationclient.py b/synapse/http/matrixfederationclient.py
-index 7fa295c..091a9c2 100644
---- a/synapse/http/matrixfederationclient.py
-+++ b/synapse/http/matrixfederationclient.py
-@@ -16,7 +16,7 @@
-
- from twisted.internet import defer, reactor, protocol
- from twisted.internet.error import DNSLookupError
--from twisted.web.client import readBody, _AgentBase, _URI, HTTPConnectionPool
-+from twisted.web.client import readBody, _AgentBase, URI, HTTPConnectionPool
- from twisted.web.http_headers import Headers
- from twisted.web._newclient import ResponseDone
-
-@@ -67,7 +67,7 @@ class MatrixFederationHttpAgent(_AgentBase):
- port = 0
- fragment = b""
-
-- parsed_URI = _URI(b"http", destination, host, port, path, params,
-+ parsed_URI = URI(b"http", destination, host, port, path, params,
- query, fragment)
-
- # Set the connection pool key to be the destination.
-diff --git a/synapse/python_dependencies.py b/synapse/python_dependencies.py
-index 8b45741..e4261eb 100644
---- a/synapse/python_dependencies.py
-+++ b/synapse/python_dependencies.py
-@@ -19,7 +19,7 @@ logger = logging.getLogger(__name__)
-
- REQUIREMENTS = {
- "syutil>=0.0.7": ["syutil>=0.0.7"],
-- "Twisted==14.0.2": ["twisted==14.0.2"],
-+ "Twisted==15.1.0": ["twisted==15.1.0"],
- "service_identity>=1.0.0": ["service_identity>=1.0.0"],
- "pyopenssl>=0.14": ["OpenSSL>=0.14"],
- "pyyaml": ["yaml"],