summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGitHub Action2024-04-21 08:16:17 +0000
committerGitHub Action2024-04-21 08:16:17 +0000
commit62af8b4f8c884499186c4b7160c07408d6c06903 (patch)
treeda55de44f00d633ee45b65784a3dcc1ccc56e547
parentf5625ee4916d37ab218e9411a3f5efb4562a2fd2 (diff)
downloadaur-62af8b4f8c884499186c4b7160c07408d6c06903.tar.gz
Update from GitHub Actions: matrix-webcam-git: update PKGBUILD
https://github.com/RiverOnVenus/AUR-packages/actions/runs/8771259555
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD9
2 files changed, 8 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 26ac55d9c3e2..1129a3f5d601 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -6,12 +6,14 @@ pkgbase = matrix-webcam-git
arch = any
license = MIT
makedepends = git
+ makedepends = python-build
+ makedepends = python-installer
+ makedepends = python-wheel
+ makedepends = python-setuptools
depends = python
depends = python-numpy
depends = python-opencv
depends = python-mediapipe-bin
- depends = python-setuptools
- depends = python-importlib-metadata
provides = matrix-webcam
conflicts = matrix-webcam
source = matrix-webcam-git::git+https://github.com/joschuck/matrix-webcam
diff --git a/PKGBUILD b/PKGBUILD
index b9e8d8441bd4..2a77f3f91e8d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,9 +11,8 @@ depends=(
'python-numpy'
'python-opencv'
'python-mediapipe-bin'
- 'python-setuptools'
- 'python-importlib-metadata')
-makedepends=('git')
+ )
+makedepends=('git' 'python-build' 'python-installer' 'python-wheel' 'python-setuptools')
provides=('matrix-webcam')
conflicts=('matrix-webcam')
source=("$pkgname"::"git+${url}")
@@ -26,11 +25,11 @@ pkgver() {
build() {
cd $pkgname
- python setup.py build
+ python -m build --wheel --no-isolation
}
package() {
cd $pkgname
- python setup.py install --root="$pkgdir" --optimize=1
+ python -m installer --destdir="$pkgdir" dist/*.whl
install -Dm644 "$srcdir/$pkgname/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}