summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGitHub Action2024-04-16 11:13:26 +0000
committerGitHub Action2024-04-16 11:13:26 +0000
commitf5625ee4916d37ab218e9411a3f5efb4562a2fd2 (patch)
tree34275b4cda6b3862067e29f0aa332cb570c79b72
downloadaur-f5625ee4916d37ab218e9411a3f5efb4562a2fd2.tar.gz
Update from GitHub Actions: matrix-webcam-git: update depends
https://github.com/RiverOnVenus/AUR-packages/actions/runs/8704587243
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD36
2 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..26ac55d9c3e2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = matrix-webcam-git
+ pkgdesc = Take your video conference from within the matrix
+ pkgver = 0.4.2.r0.g7cbc54c
+ pkgrel = 1
+ url = https://github.com/joschuck/matrix-webcam
+ arch = any
+ license = MIT
+ makedepends = git
+ depends = python
+ depends = python-numpy
+ depends = python-opencv
+ depends = python-mediapipe-bin
+ depends = python-setuptools
+ depends = python-importlib-metadata
+ provides = matrix-webcam
+ conflicts = matrix-webcam
+ source = matrix-webcam-git::git+https://github.com/joschuck/matrix-webcam
+ sha256sums = SKIP
+
+pkgname = matrix-webcam-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b9e8d8441bd4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: RiverOnVenus <error@zhui.dev>
+pkgname=matrix-webcam-git
+pkgver=0.4.2.r0.g7cbc54c
+pkgrel=1
+pkgdesc="Take your video conference from within the matrix"
+arch=('any')
+url="https://github.com/joschuck/matrix-webcam"
+license=('MIT')
+depends=(
+ 'python'
+ 'python-numpy'
+ 'python-opencv'
+ 'python-mediapipe-bin'
+ 'python-setuptools'
+ 'python-importlib-metadata')
+makedepends=('git')
+provides=('matrix-webcam')
+conflicts=('matrix-webcam')
+source=("$pkgname"::"git+${url}")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd $pkgname
+ git describe --long --tags --abbrev=7 | sed 's/^v//;s/-/.r/;s/-/./'
+}
+
+build() {
+ cd $pkgname
+ python setup.py build
+}
+
+package() {
+ cd $pkgname
+ python setup.py install --root="$pkgdir" --optimize=1
+ install -Dm644 "$srcdir/$pkgname/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}