summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Liu2022-12-30 22:49:09 -0500
committerDaniel Liu2022-12-30 22:49:09 -0500
commit79c8bd81739e0f832b2de822bff61f6ccc037211 (patch)
treeddd2b8e82c29edae1c9424f91c34903d27f49b7e
downloadaur-79c8bd81739e0f832b2de822bff61f6ccc037211.tar.gz
v1.0
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD21
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ff7eb493ebfb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = matsuba-bin
+ pkgdesc = lightweight japanese ime written in rust
+ pkgver = 1.0
+ pkgrel = 1
+ url = https://github.com/MrPicklePinosaur/matsuba
+ arch = x86_64
+ license = MIT
+ license = Apache
+ makedepends = cargo
+ depends = xdotool
+ depends = xmodmap
+ depends = sqlite3
+ provides = matsud
+ provides = matsucli
+ source = https://github.com/MrPicklePinosaur/matsuba/releases/download/v1.0/matsuba-linux.zip
+ md5sums = SKIP
+
+pkgname = matsuba-bin
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..43d224c2f1d9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+#Maintainers: MrPicklePinosaur
+pkgname=matsuba-bin
+pkgver=1.0
+pkgrel=1
+pkgdesc="lightweight japanese ime written in rust"
+arch=('x86_64')
+url="https://github.com/MrPicklePinosaur/matsuba"
+license=('MIT' 'Apache')
+groups=()
+provides=(matsud matsucli)
+depends=(xdotool xmodmap sqlite3)
+makedepends=(cargo)
+source=("$url/releases/download/v${pkgver}/matsuba-linux.zip")
+md5sums=('SKIP')
+
+package() {
+ install -Dm755 matsud "${pkgdir}/usr/bin/matsud"
+ install -Dm755 matsucli "${pkgdir}/usr/bin/matsucli"
+ install -Dm644 matsuba_default.toml "${pkgdir}/usr/share/matsuba/matsuba_default.toml"
+}
+