summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlex J. Malozemoff2018-08-14 09:01:30 -0700
committerAlex J. Malozemoff2018-08-14 09:01:30 -0700
commit0dac89478f24a3a78523fb9ca4a5ebc184e48ba7 (patch)
treef66662db4239ba18f949be89faca9e1dcedfbaf6
parent88007455370b25d1433ed285711429b3aa1dfedd (diff)
downloadaur-0dac89478f24a3a78523fb9ca4a5ebc184e48ba7.tar.gz
build matterhorn from source (matterhorn-bin now contains the binary build)
-rw-r--r--PKGBUILD29
1 files changed, 15 insertions, 14 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e8bb749b17b5..01e8fe03f416 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,26 @@
# Maintainer: Alex J. Malozemoff <amaloz@galois.com>
pkgname=matterhorn
pkgver=40901.0.0
-pkgrel=1
+pkgrel=2
pkgdesc="A terminal-based chat client for MatterMost"
-arch=('x86_64')
+arch=('any')
url="https://github.com/matterhorn-chat/matterhorn"
license=('BSD')
provides=('matterhorn')
-conflicts=('matterhorn-git')
+conflicts=('matterhorn-git' 'matterhorn-bin')
depends=('ncurses5-compat-libs')
-replaces=()
-backup=()
-options=()
-install=
-changelog=
-source=("https://github.com/matterhorn-chat/matterhorn/releases/download/${pkgver}/matterhorn-${pkgver}-ubuntu-x86_64.tar.bz2")
-sha1sums=('558245deb32851cb39df761cfc40fed887e75990')
-noextract=()
+makedepends=('git' 'cabal-install')
+source=("https://github.com/matterhorn-chat/matterhorn/archive/${pkgver}.tar.gz")
+sha1sums=('183fc10600066a1ad47d235fc29597300eb14ca3')
+
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ ./install.sh
+}
package() {
- cd "$srcdir/$pkgname-$pkgver-Ubuntu-x86_64"
- mkdir -p "$pkgdir/usr/bin"
- cp matterhorn "$pkgdir/usr/bin"
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ install -m755 -D $(find . -name "matterhorn" -type f) "${pkgdir}"/usr/bin/matterhorn
+ install -m644 -D LICENSE "${pkgdir}"/usr/share/licenses/matterhorn/LICENSE
}