summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlex J. Malozemoff2018-12-04 15:50:59 -0800
committerAlex J. Malozemoff2018-12-04 15:50:59 -0800
commit549a0ee23da403275f514801a42fa3f0a1f18dff (patch)
tree2e02222449967a49f6110e279fde312cb143bb44
parenta8a3f0c2752e374bbd0fd7df98ddd9b8ab2959fd (diff)
downloadaur-549a0ee23da403275f514801a42fa3f0a1f18dff.tar.gz
make namcap (mostly) happy
-rw-r--r--.SRCINFO7
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD17
3 files changed, 17 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6857e661a754..66a2dedc6d40 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,21 @@
pkgbase = matterhorn-bin
pkgdesc = A terminal-based chat client for MatterMost
pkgver = 50200.0.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/matterhorn-chat/matterhorn
arch = x86_64
license = BSD
+ depends = gmp
+ depends = libffi
depends = ncurses5-compat-libs
+ depends = zlib
provides = matterhorn-bin
conflicts = matterhorn
conflicts = matterhorn-git
source = https://github.com/matterhorn-chat/matterhorn/releases/download/50200.0.0/matterhorn-50200.0.0-ubuntu-x86_64.tar.bz2
+ source = LICENSE::https://github.com/matterhorn-chat/matterhorn/raw/master/LICENSE
sha1sums = b5c3baa6b9de25b938da2624ec4631f6398d87ff
+ sha1sums = 42e13363365a1fed1318f9e7fadd8d1760e7ba95
pkgname = matterhorn-bin
diff --git a/.gitignore b/.gitignore
index 54f60cf993a7..a681121d3664 100644
--- a/.gitignore
+++ b/.gitignore
@@ -3,3 +3,4 @@
*.tar.bz2
pkg/
src/
+LICENSE
diff --git a/PKGBUILD b/PKGBUILD
index ca5653278b8d..af963aa27c90 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,22 @@
# Maintainer: Alex J. Malozemoff <amaloz@galois.com>
pkgname=matterhorn-bin
pkgver=50200.0.0
-pkgrel=1
+pkgrel=2
pkgdesc="A terminal-based chat client for MatterMost"
arch=('x86_64')
url="https://github.com/matterhorn-chat/matterhorn"
license=('BSD')
provides=('matterhorn-bin')
conflicts=('matterhorn' 'matterhorn-git')
-depends=('ncurses5-compat-libs')
-source=("https://github.com/matterhorn-chat/matterhorn/releases/download/${pkgver}/matterhorn-${pkgver}-ubuntu-x86_64.tar.bz2")
-sha1sums=('b5c3baa6b9de25b938da2624ec4631f6398d87ff')
+depends=('gmp' 'libffi' 'ncurses5-compat-libs' 'zlib')
+source=("https://github.com/matterhorn-chat/matterhorn/releases/download/${pkgver}/matterhorn-${pkgver}-ubuntu-x86_64.tar.bz2"
+ "LICENSE::https://github.com/matterhorn-chat/matterhorn/raw/master/LICENSE")
+sha1sums=('b5c3baa6b9de25b938da2624ec4631f6398d87ff'
+ '42e13363365a1fed1318f9e7fadd8d1760e7ba95')
package() {
- cd "$srcdir/matterhorn-$pkgver-Ubuntu-x86_64"
- mkdir -p "$pkgdir/usr/bin"
- cp matterhorn "$pkgdir/usr/bin"
+ install -m644 -D LICENSE ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
+ cd ${srcdir}/matterhorn-${pkgver}-Ubuntu-${arch}
+ install -m755 -D matterhorn ${pkgdir}/usr/bin/matterhorn
+
}