summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBruno Pagani2017-10-17 17:46:55 +0200
committerWilliam Gathoye2017-11-11 14:20:15 +0100
commitb3917aae14f45b9144872505e4fa56922a488524 (patch)
treebe283834aa4a6a3f8db9caf51fb35720b2f9f9ce
parent9807464ed3525e75afef40a0d7410bc92f35b576 (diff)
downloadaur-b3917aae14f45b9144872505e4fa56922a488524.tar.gz
In case we need to switch to AGPL instead of MIT
-rw-r--r--PKGBUILD12
1 files changed, 2 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index aae963759f77..fd0818319e7b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,11 +7,7 @@ pkgrel=1
pkgdesc='Open source Slack-alternative in Golang and React'
arch=('i686' 'x86_64')
url="https://mattermost.com"
-# The official releases are under MIT, while the ones compiled from the source
-# code in /platform must be under AGPL v3.
-# src.: https://pre-release.mattermost.com/core/pl/cj61agrh5jgmukxxahgdwfx5ww
-# src.: https://www.mattermost.org/licensing
-license=('MIT')
+license=('AGPL' 'Apache')
makedepends=('git' 'go' 'libpng12' 'npm' 'yarn')
optdepends=(
@@ -103,7 +99,7 @@ package() {
"${pkgdir}"/usr/share/webapps \
"${pkgdir}"/var/log/${pkgname} \
"${pkgdir}"/etc/webapps \
- "${pkgdir}"/usr/share/{licenses,doc}/${pkgname}
+ "${pkgdir}"/usr/share/doc/${pkgname}
cp -a dist/${pkgname} "${pkgdir}"/usr/share/webapps/
@@ -120,11 +116,7 @@ package() {
-e 's@tcp(dockerhost:3306)@unix(/run/mysqld/mysqld.sock)@g' \
-i "${pkgdir}"/etc/webapps/${pkgname}/config.json
- # When MIT license, the one bundled with the package must always be copied
- # on the system.
- # src.: https://wiki.archlinux.org/index.php/PKGBUILD#license
mv NOTICE.txt README.md "${pkgdir}"/usr/share/doc/${pkgname}
- mv MIT-COMPILED-LICENSE.md "${pkgdir}"/usr/share/license/${pkgname}/LICENSE
cd "${srcdir}"
install -Dm755 bin/platform -t "${pkgdir}"/usr/share/webapps/${pkgname}/bin/