summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWilliam Gathoye2019-12-02 16:21:59 +0100
committerWilliam Gathoye2019-12-02 16:21:59 +0100
commit6109725adb11e57e59f0735589b3988b8688ddf3 (patch)
tree42222a2da807994bb8df06b05523aa633992955f
parent7c431c52fe908123ccfe7f7dcd107bcad4d7cf8f (diff)
downloadaur-6109725adb11e57e59f0735589b3988b8688ddf3.tar.gz
Reduce build time
-rw-r--r--PKGBUILD8
1 files changed, 4 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9e1eda8eb106..6a484e526d7e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -64,12 +64,12 @@ prepare() {
#
# Asking upstream to switch to electron-spellchecker will fix the issue.
# https://github.com/electron-userland/electron-spellchecker
-}
-build() {
- cd "desktop-${pkgver}"
+ # Install dependencies should be in prepare(), that way we don't need an
+ # internet connection during build().
+ # We don't need to run "npm run build" because that target is run by "npm
+ # run package:linux" any way.
npm install --cache "${srcdir}/npm-cache"
- npm run build --cache "${srcdir}/npm-cache"
}
package() {