summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWilliam Gathoye2017-07-09 16:18:32 +0200
committerWilliam Gathoye2017-07-10 15:19:12 +0200
commit2832b0ad820e91565a29706b7740c0e18261d720 (patch)
tree0cd71791aaf86bec35702c737ec0e60acc077e23
parent56ff741be2c8d5fc6f6d85a5f69f637978a7e529 (diff)
downloadaur-2832b0ad820e91565a29706b7740c0e18261d720.tar.gz
Add note for local tests
-rw-r--r--PKGBUILD10
1 files changed, 9 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c9be49fc6f6b..291974f1bc86 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=mattermost-git
_pkgname="${pkgname%-git}"
-pkgver=3.9.0.rc1.r0.g52b5c74a0
+pkgver=4.0.0.rc2.r0.ge5912d4f9
pkgrel=1
pkgdesc="Open source Slack-alternative in Golang and React"
arch=('i686' 'x86_64')
@@ -27,6 +27,10 @@ source=(
# The mattermost repo is quite huge. Consider manually cloning the
# repository first, either a full clone or with the --dept argument. You
# can also specify the --depth git argument in your in makepkg.conf file.
+ # For local tests, simply replace this git URL by
+ # For the URL syntax, please check this link:
+ # https://wiki.archlinux.org/index.php/VCS_package_guidelines#VCS_sources
+ # platform::git+file:///home/whatever/repo
'git+https://github.com/mattermost/platform'
'mattermost.service'
'mattermost.sh'
@@ -72,6 +76,10 @@ prepare() {
ln -s "$srcdir"/platform platform
cd platform
+ # Prevent the build to crash when some dependencies are not met or
+ # outdated.
+ make clean
+
# Remove platform specific lines from the Makefile from the line beginning
# with "cp README.md" to the line beginning with run-server
sed -n '1,/cp README.md/p;/^run-server:/,$p' -i Makefile