summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWilliam Gathoye2017-08-26 01:25:24 +0200
committerWilliam Gathoye2017-08-26 01:25:24 +0200
commitf304c8626e89a41c177350cf6626354ea3bd804a (patch)
tree909426c4407fd856f2887cadb701a48484836fad
parent07d5192b6814da5d1a589877224e513428dba88d (diff)
downloadaur-f304c8626e89a41c177350cf6626354ea3bd804a.tar.gz
Remove pngquant from build requirements
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD14
2 files changed, 10 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7f60bbaa4e9e..e4de1a5ca81b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,15 @@
pkgbase = mattermost-git
pkgdesc = Open source Slack-alternative in Golang and React
- pkgver = 4.0.0.rc2.r214.ga6ba5a5e7
+ pkgver = 4.1.0.r64.gc81d0f120
pkgrel = 1
url = http://mattermost.org
arch = i686
arch = x86_64
license = AGPL3
- makedepends = go
- makedepends = npm
makedepends = git
+ makedepends = go
makedepends = libpng12
- makedepends = pngquant
+ makedepends = npm
makedepends = yarn
optdepends = mariadb: SQL server storage
optdepends = percona-server: SQL server storage
diff --git a/PKGBUILD b/PKGBUILD
index 2959bc7de795..610ee79d6f45 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=mattermost-git
_pkgname="${pkgname%-git}"
-pkgver=4.0.0.rc2.r214.ga6ba5a5e7
+pkgver=4.1.0.r64.gc81d0f120
pkgrel=1
pkgdesc="Open source Slack-alternative in Golang and React"
arch=('i686' 'x86_64')
@@ -14,7 +14,7 @@ url="http://mattermost.org"
# src.: https://www.mattermost.org/licensing
license=('AGPL3')
-makedepends=('go' 'npm' 'git' 'libpng12' 'pngquant' 'yarn')
+makedepends=('git' 'go' 'libpng12' 'npm' 'yarn')
provides=('mattermost')
conflicts=('mattermost')
backup=('etc/webapps/mattermost/config.json')
@@ -76,14 +76,14 @@ prepare() {
# with "cp README.md" to the line beginning with run-server
sed -n '1,/cp README.md/p;/^run-server:/,$p' -i Makefile
+ # Build build-linux directly, because the package target in the
+ # Makefile has as dependency build which itself has build-linux,
+ # build-osx and build-windows as dependencies.
+ #
+ # Remove GOARCH=amd64 statement
sed -E -i Makefile \
-e 's/^package: build build-client/package: build-linux build-client/' \
-e 's/GOARCH=amd64//'
-
- # Use system pngquant instead of the one bundled with the app. Add rm and
- # ln instruction after the line 'npm install'.
- sed -i webapp/Makefile \
- -e '/npm install/a \ rm node_modules/pngquant-bin/vendor/pngquant\n ln -s /usr/bin/pngquant node_modules/pngquant-bin/vendor/pngquant'
}
build() {