summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCaleb Maclennan2023-01-17 17:43:27 +0300
committerCaleb Maclennan2023-01-17 17:47:48 +0300
commit415aebedce39e248e48693291e4831a241253db3 (patch)
treeb940f5ac6a30e4a6546b491f530ccc9f670ae794
downloadaur-415aebedce39e248e48693291e4831a241253db3.tar.gz
Initial upload: mattermost-plugin-calls 0.12.1-1
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD27
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..cf787da63ce9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = mattermost-plugin-calls
+ pkgdesc = enables voice calling and screen sharing functionality in Mattermost channels
+ pkgver = 0.12.1
+ pkgrel = 1
+ url = https://github.com/mattermost/mattermost-plugin-calls
+ arch = x86_64
+ license = MIT
+ depends = mattermost>=7.6.0
+ options = !strip
+ source = https://github.com/mattermost/mattermost-plugin-calls/releases/download/v0.12.1/com.mattermost.calls-0.12.1.tar.gz
+ sha256sums = 3ad3a9441a68b7be8f8364547bbc1a6955dd8d7bad4e61899adc75abefd5a81d
+
+pkgname = mattermost-plugin-calls
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..be7aef0fc1a8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Caleb Maclennan <caleb@alerque.com>
+
+pkgname=mattermost-plugin-calls
+pkgver=0.12.1
+pkgrel=1
+pkgdesc='enables voice calling and screen sharing functionality in Mattermost channels'
+arch=(x86_64)
+url="https://github.com/${pkgname%%-*}/$pkgname"
+license=(MIT)
+# jq -r .min_server_version mattermost-plugin/plugin.json
+depends=('mattermost>=7.6.0')
+options=(!strip)
+_plugin="com.mattermost.${pkgname##*-}"
+_archive="$_plugin-$pkgver"
+source=("$url/releases/download/v$pkgver/$_archive.tar.gz")
+sha256sums=('3ad3a9441a68b7be8f8364547bbc1a6955dd8d7bad4e61899adc75abefd5a81d')
+
+# Note the intention of this package is to bulid from source, but I haven't
+# gotten it to work yet. Contributions welcome! Temporarily it is installing
+# the upstream generated binary version.
+
+package() {
+ local _plugins="$pkgdir/var/lib/mattermost/plugins"
+ install -dm0755 "$_plugins"
+ cp -r "$_plugin" "$_plugins"
+}
+