summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCaleb Maclennan2023-03-09 11:04:27 +0300
committerCaleb Maclennan2023-03-09 11:04:27 +0300
commitad84d6a4669765fae84ee5a68bb5fb0f28bbff32 (patch)
tree6ba7e6b7a5e88eb2df5d072b7b1af6cba48a1c82
parent5b0eacb919661e4e678707565d7c05f079863fd4 (diff)
downloadaur-ad84d6a4669765fae84ee5a68bb5fb0f28bbff32.tar.gz
upgpkg: mattermost-plugin-calls 0.14.0-1
upstream release
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD28
2 files changed, 24 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a981a60eb9bb..a94bd4081add 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,13 @@
pkgbase = mattermost-plugin-calls
pkgdesc = enables voice calling and screen sharing functionality in Mattermost channels
- pkgver = 0.13.0
+ pkgver = 0.14.0
pkgrel = 1
url = https://github.com/mattermost/mattermost-plugin-calls
arch = x86_64
license = MIT
- depends = mattermost>=7.6.0
+ makedepends = jq
options = !strip
- source = https://github.com/mattermost/mattermost-plugin-calls/releases/download/v0.13.0/com.mattermost.calls-0.13.0.tar.gz
- sha256sums = 66ae2f46e44affaeabcfae280ff1bffcc2d311da69f5ef21459de600a57211b4
+ source = https://github.com/mattermost/mattermost-plugin-calls/releases/download/v0.14.0/com.mattermost.calls-0.14.0.tar.gz
+ sha256sums = 1f71ae08eb8b7de99a0eedfc3c7a9fd06fffb650342d26758a53dee9b24e05cd
pkgname = mattermost-plugin-calls
diff --git a/PKGBUILD b/PKGBUILD
index 5aa9dd81e585..464453025299 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,39 @@
# Maintainer: Caleb Maclennan <caleb@alerque.com>
+# Note the intention of this package is to bulid from source, but I haven't
+# gotten it to work yet. Contributions welcome! Temporarily it is installing
+# the upstream generated binary version.
+
pkgname=mattermost-plugin-calls
-pkgver=0.13.0
+pkgver=0.14.0
pkgrel=1
pkgdesc='enables voice calling and screen sharing functionality in Mattermost channels'
arch=(x86_64)
url="https://github.com/${pkgname%%-*}/$pkgname"
license=(MIT)
-# jq -r .min_server_version mattermost-plugin/plugin.json
-depends=('mattermost>=7.6.0')
+makedepends=(jq)
options=(!strip)
_plugin="com.mattermost.${pkgname##*-}"
_archive="$_plugin-$pkgver"
source=("$url/releases/download/v$pkgver/$_archive.tar.gz")
-sha256sums=('66ae2f46e44affaeabcfae280ff1bffcc2d311da69f5ef21459de600a57211b4')
+sha256sums=('1f71ae08eb8b7de99a0eedfc3c7a9fd06fffb650342d26758a53dee9b24e05cd')
-# Note the intention of this package is to bulid from source, but I haven't
-# gotten it to work yet. Contributions welcome! Temporarily it is installing
-# the upstream generated binary version.
+# BEGIN boilerplate mattermost plugin version clamping, see also other packages in group
+# 1. Call respective function helper in package() *after* cd'ing to the source directory
+# 2. Add makedepends+=(jq)
+_get_supported_ranges() {
+ _plugin_min_mattermost="$(< plugin.json jq -r '.min_server_version')"
+}
+_mattermost_plugin_package() {
+ _get_supported_ranges
+ depends+=("mattermost>=${_plugin_min_mattermost:-0}")
+}
+# END boilerplate mattermost plugin version clamping
package() {
local _plugins="$pkgdir/var/lib/mattermost/plugins"
install -dm0755 "$_plugins"
cp -r "$_plugin" "$_plugins"
+ cd "$_plugin"
+ _mattermost_plugin_package
}
-