summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCaleb Maclennan2022-02-19 13:19:08 +0300
committerCaleb Maclennan2022-02-19 13:19:08 +0300
commit8541e90133d68416e7f115b3581cc99ae350256c (patch)
treef60dbf333a39dd57d0775e05372f3425c875f232
downloadaur-8541e90133d68416e7f115b3581cc99ae350256c.tar.gz
Initial upload: mattermost-plugin-focalboard 0.14.0-1
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD25
2 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8cf1ad5e0b90
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = mattermost-plugin-focalboard
+ pkgdesc = an open source, self-hosted alternative to Trello, Notion, and Asana
+ pkgver = 0.14.0
+ pkgrel = 1
+ url = https://www.focalboard.com
+ arch = x86_64
+ depends = mattermost
+ options = !strip
+ source = mattermost-plugin-focalboard-0.14.0.tgz::https://github.com/mattermost/focalboard/releases/download/v0.14.0/mattermost-plugin-focalboard.tar.gz
+ sha256sums = 39d53c6638780d9e0ecc67ea06dbaf14ff473103868a01b4a5e2575e9c316952
+
+pkgname = mattermost-plugin-focalboard
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ece0b5be2b83
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Caleb Maclennan <caleb@alerque.com>
+
+pkgname=mattermost-plugin-focalboard
+pkgver=0.14.0
+pkgrel=1
+pkgdesc='an open source, self-hosted alternative to Trello, Notion, and Asana'
+arch=(x86_64)
+url=https://www.focalboard.com
+_url="https://github.com/${pkgname%%-*}/${pkgname##*-}"
+license=()
+depends=(mattermost)
+options=(!strip)
+_archive="$pkgname-$pkgver"
+source=("$_archive.tgz::$_url/releases/download/v$pkgver/$pkgname.tar.gz")
+sha256sums=('39d53c6638780d9e0ecc67ea06dbaf14ff473103868a01b4a5e2575e9c316952')
+
+# Note the intention of this package is to bulid from source, but I haven't
+# gotten it to work yet. Contributions welcome! Temporarily it is installing
+# the upstream generated binary version.
+
+package() {
+ local _plugins="$pkgdir/var/lib/mattermost/plugins"
+ install -dm0755 "$_plugins"
+ cp -r focalboard "$_plugins"
+}